Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

net: TestMulticastListener failing on tip darwin/amd64, OS X 10.7.3 #3352

Closed
jmhodges opened this issue Mar 19, 2012 · 7 comments

Comments

Projects
None yet
6 participants
@jmhodges
Copy link
Contributor

commented Mar 19, 2012

→  ./all.bash 
...
--- FAIL: TestMulticastListener (0.00 seconds)
    multicast_test.go:69: First ListenMulticastUDP failed: joinipv4group udp 224.0.0.254: setsockopt: can't assign requested address
FAIL
FAIL    net 0.893s
...

Which compiler are you using (5g, 6g, 8g, gccgo)?
6g

Which operating system are you using?
OS X 10.7.3

Which revision are you using?  (hg identify)
a216dfd16073 tip
@jmhodges

This comment has been minimized.

Copy link
Contributor Author

commented Mar 19, 2012

Comment 1:

Ah, suck. This only occurs while on a Network Connect VPN.
We can close this up, or I can provide further information for those who care.
@dsymonds

This comment has been minimized.

Copy link
Member

commented Mar 19, 2012

Comment 2:

See if you can track down more information. This could be an edge case we just haven't
tickled before.

Labels changed: added priority-later, removed priority-triage.

Status changed to WaitingForReply.

@theclapp

This comment has been minimized.

Copy link
Contributor

commented Aug 16, 2012

Comment 3:

I got something similar for ipv6:
./all.bash
...
--- FAIL: TestMulticastListener (0.00 seconds)
        multicast_test.go:69: First ListenMulticastUDP failed: joinipv6group udp ff0e::114: setsockopt: can't assign requested address
FAIL
FAIL    net     1.206s
...
go version => 1.0.2
uname -a => Darwin donner.local 11.4.0 Darwin Kernel Version 11.4.0: Mon Apr  9 19:32:15
PDT 2012; root:xnu-1699.26.8~1/RELEASE_X86_64 x86_64
@mikioh

This comment has been minimized.

Copy link
Contributor

commented Aug 16, 2012

Comment 4:

Hi, thanks for your report.
The case #3, yes.
The test fails when the node under tests has no global-scope 
IPv6 addresses. I sent a fix patch and submitted a week or two.
But the case in #1... how could it be?

Status changed to HelpWanted.

@rsc

This comment has been minimized.

Copy link
Contributor

commented Sep 12, 2012

Comment 5:

Labels changed: added go1.1maybe.

@mikioh

This comment has been minimized.

Copy link
Contributor

commented Mar 8, 2013

Comment 6:

Status changed to Duplicate.

Merged into issue #4059.

@mikioh

This comment has been minimized.

Copy link
Contributor

commented Mar 8, 2013

Comment 7:

Hi,
I think
https://code.google.com/p/go/source/detail?r=5b76706b55af
fixes this issue too.

@rsc rsc added this to the Go1.1 milestone Apr 14, 2015

@rsc rsc removed the go1.1maybe label Apr 14, 2015

@golang golang locked and limited conversation to collaborators Jun 24, 2016

This issue was closed.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.