Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/tools/gopls: LSP errors when navigating through 'git' and 'gitlens' files #33699

Open
inliquid opened this issue Aug 17, 2019 · 2 comments

Comments

@inliquid
Copy link

commented Aug 17, 2019

VS Code. Here is what I get into after navigating over some history with Gitlens extension.
изображение

gopls returns a lot of errors, in spite that files are actually ok. Other that that I must admit that most of features work, so for instance I can navigate and see some documentation on hover in both git panes. Not for all elements however. One annoying thing is these errors. However, if I close the window, they'll disappear.

@gopherbot gopherbot added this to the Unreleased milestone Aug 17, 2019

@gopherbot gopherbot added the gopls label Aug 17, 2019

@gopherbot

This comment has been minimized.

Copy link

commented Aug 17, 2019

Thank you for filing a gopls issue! Please take a look at the Troubleshooting section of the gopls Wiki page, and make sure that you have provided all of the relevant information here.

@inliquid

This comment has been minimized.

Copy link
Author

commented Aug 17, 2019

Same thing with 'git' urls.

@inliquid inliquid changed the title x/tools/gopls: LSP errors when navigating through 'gitlens' files x/tools/gopls: LSP errors when navigating through 'git' and 'gitlens' files Aug 17, 2019

@gopherbot gopherbot added the Tools label Sep 12, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.