Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/build/cmd/coordinator: no "Trybots beginning" message when running multiple times on the same patchset #38235

Closed
stamblerre opened this issue Apr 3, 2020 · 3 comments

Comments

@stamblerre
Copy link
Contributor

@stamblerre stamblerre commented Apr 3, 2020

I occasionally want to run TryBots multiple times on the same patchset. Based on the behavior on https://golang.org/cl/227117, it seems like this works, but it doesn't send out the "TryBots beginning" message with a link to their progress. This makes me think that the TryBots aren't running.

/cc @dmitshur @cagedmantis @toothrot

@dmitshur
Copy link
Contributor

@dmitshur dmitshur commented Apr 3, 2020

Thanks for reporting. This is indeed a problem for usability. (CC @prattmic who's run into this too.)

The reason it happens is because the message that coordinator constructs when trybots are restarted on the same commit ends up being identical to a previously posted one (because the commit hash is unchanged), and there is code to prevent duplicate messages from being posted:

https://github.com/golang/build/blob/61705b562fc995a53af15476c91f6ad3dcf1aae8/cmd/coordinator/coordinator.go#L1363

When that spam filter was created, we probably didn't anticipate this situation where duplicate messages are expected.

We should fix this either by adjusting the spam filter to permit duplicate "TryBots beginning" messages, or perhaps better, make it so that the message it posts isn't duplicate by adding " (attempt 2)", " (attempt 3)", etc., suffixes (if it's not too hard to compute what attempt it is).

@dmitshur dmitshur changed the title x/build: no "Trybots beginning" message when running multiple times on the same patchset x/build/cmd/coordinator: no "Trybots beginning" message when running multiple times on the same patchset Apr 3, 2020
@gopherbot
Copy link

@gopherbot gopherbot commented Apr 6, 2020

Change https://golang.org/cl/227319 mentions this issue: cmd/coordinator: add attempt prefix to TryBot runs

@dmitshur
Copy link
Contributor

@dmitshur dmitshur commented Apr 20, 2021

Based on commit message and discussion in CL 310186,
I understand this is fixed in golang/build@c328b27 (CL 310015).
(CC @FiloSottile, @ianlancetaylor.)

@dmitshur dmitshur closed this Apr 20, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

3 participants