Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problem with installing Go for the first time: Access denied Error! #40193

Closed
StefanoCoss opened this issue Jul 13, 2020 · 1 comment
Closed

Problem with installing Go for the first time: Access denied Error! #40193

StefanoCoss opened this issue Jul 13, 2020 · 1 comment

Comments

@StefanoCoss
Copy link

@StefanoCoss StefanoCoss commented Jul 13, 2020

What version of Go are you using (go version)?

$ go version
go version go1.14.4 windows/amd64

Does this issue reproduce with the latest release?

What operating system and processor architecture are you using (go env)?

go env Output
$ go env
set GO111MODULE=
set GOARCH=amd64
set GOBIN=
set GOCACHE=C:\Users\Stefano\AppData\Local\go-build
set GOENV=C:\Users\Stefano\AppData\Roaming\go\env
set GOEXE=.exe
set GOFLAGS=
set GOHOSTARCH=amd64
set GOHOSTOS=windows
set GOINSECURE=
set GONOPROXY=
set GONOSUMDB=
set GOOS=windows
set GOPATH=C:\Users\Stefano\go
set GOPRIVATE=
set GOPROXY=https://proxy.golang.org,direct
set GOROOT=c:\go
set GOSUMDB=sum.golang.org
set GOTMPDIR=
set GOTOOLDIR=c:\go\pkg\tool\windows_amd64
set GCCGO=gccgo
set AR=ar
set CC=gcc
set CXX=g++
set CGO_ENABLED=1
set GOMOD=
set CGO_CFLAGS=-g -O2
set CGO_CPPFLAGS=
set CGO_CXXFLAGS=-g -O2
set CGO_FFLAGS=-g -O2
set CGO_LDFLAGS=-g -O2
set PKG_CONFIG=pkg-config
set GOGCCFLAGS=-m64 -mthreads -fno-caret-diagnostics -Qunused-arguments -fmessage-length=0 -fdebug-prefix-map=C:\Users\Stefano\AppData\Local\Temp\go-build996902630=/tmp/go-build -gno-record-gcc-switches
GOROOT/bin/go version: go version go1.14.4 windows/amd64
GOROOT/bin/go tool compile -V: compile version go1.14.4

What did you do?

Hello, I have a problem while installing Go for the first time. I create the hello.go file as described in the "getting started" docs, and execute the file using PS through >>go run hello.go.

Nothing happens and it outputs in the terminal:

fork/exec C:\Users\Stefano\AppData\Local\Temp\go-build648156882\b001\exe\hello.exe: Access is denied.

What did you expect to see?

The ececute of the hello.go file

What did you see instead?

fork/exec C:\Users\Stefano\AppData\Local\Temp\go-build648156882\b001\exe\hello.exe: Access is denied.

Thanks for your help!

Stefano

@agnivade
Copy link
Contributor

@agnivade agnivade commented Jul 14, 2020

Hi @StefanoCoss - this does not look to be a bug in Go. Unlike other projects, we do not use the issue tracker for questions such as these. It is only used for bugs and feature proposals. I will close this issue, but please feel free to ask it in any of these forums below:

Thanks

@agnivade agnivade closed this Jul 14, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.