Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/pkgsite: search input rendering delay on initial load #40857

Open
myitcv opened this issue Aug 18, 2020 · 4 comments
Open

x/pkgsite: search input rendering delay on initial load #40857

myitcv opened this issue Aug 18, 2020 · 4 comments

Comments

@myitcv
Copy link
Member

@myitcv myitcv commented Aug 18, 2020

What is the URL of the page with the issue?

https://pkg.go.dev/

What is your user agent?

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.59 Safari/537.36

Screenshot

Screen Shot 2020-08-18 at 11 35 02

What did you do?

  • Open a new tab in Chrome
  • Type pkg., and then hit Enter to accept the selected Chrome suggestion of https://pkg.go.dev
  • As soon as the page loads and the focus is placed in the search box, start typing to find the module/package I am looking for

What did you expect to see?

The text I am typing in the search box to appear immediately

What did you see instead?

A noticeable lag in the text being rendered - it's as if the page load is blocked/waiting on something

See repro: https://youtu.be/nkPq6Sbm2wY

Note that this delay is most notable when I have a scaled display setting:

Screen Shot 2020-08-18 at 11 48 58

@julieqiu
Copy link
Contributor

@julieqiu julieqiu commented Aug 18, 2020

/cc @jamalc

@myitcv
Copy link
Member Author

@myitcv myitcv commented Aug 27, 2020

FWIW I also notice a delay when visiting https://golang.org/ref/spec and once the page is loaded hitting Command-f to search within the page: Chrome appears to hang before displaying the search box.

@julieqiu julieqiu modified the milestones: Unreleased, pkgsite/frontend Aug 27, 2020
@myitcv
Copy link
Member Author

@myitcv myitcv commented Aug 29, 2020

This could well be related to #40959

@myitcv
Copy link
Member Author

@myitcv myitcv commented Sep 7, 2020

More details: I can't replicate this in incognito mode.

@gopherbot gopherbot added the go.dev label Sep 18, 2020
@julieqiu julieqiu removed the go.dev label Sep 19, 2020
@gopherbot gopherbot added the go.dev label Sep 19, 2020
@julieqiu julieqiu removed the go.dev label Sep 19, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.