Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/pkgsite: use go 1.19 go/doc #41530

Closed
jba opened this issue Sep 21, 2020 · 2 comments
Closed

x/pkgsite: use go 1.19 go/doc #41530

jba opened this issue Sep 21, 2020 · 2 comments
Assignees
Labels
NeedsFix pkgsite

Comments

@jba
Copy link
Contributor

@jba jba commented Sep 21, 2020

Now that App Engine supports Go 1.14, we can replace our fork of go/doc with the standard library package.

@jba jba added NeedsFix pkgsite labels Sep 21, 2020
@jba jba added this to the pkgsite/unplanned milestone Sep 21, 2020
@jba jba self-assigned this Sep 21, 2020
@julieqiu julieqiu removed the website label Sep 22, 2020
@julieqiu julieqiu removed the website label Sep 22, 2020
@jba
Copy link
Contributor Author

@jba jba commented May 31, 2022

After this issue was originally filed, the pkgsite fork diverged further, making it hard to unfork.

With the improvements to godoc scheduled to land in Go 1.19, it is now finally time to complete this. I've already applied all pkgsite improvements to go/doc, so nothing is blocking this work except the 1.19 release itself.

@jba jba changed the title x/pkgsite: use go 1.14 go/doc x/pkgsite: use go 1.19 go/doc May 31, 2022
@jba
Copy link
Contributor Author

@jba jba commented Jun 29, 2022

Fixed in https://go.dev/cl/413316.

@jba jba closed this as completed Jun 29, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
NeedsFix pkgsite
Projects
None yet
Development

No branches or pull requests

3 participants