Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/build/cmd/coordinator: warn if a slowbot is requested on a Go version that is known to be unsupported by the builder #41831

Open
dmitshur opened this issue Oct 7, 2020 · 0 comments

Comments

@dmitshur
Copy link
Contributor

@dmitshur dmitshur commented Oct 7, 2020

If we can determine that the following two conditions are true:

  • a builder requires at least Go 1.N or at most Go 1.M (e.g., via the MinimumGoVersion field or similar)
  • the commit being asked for testing represents a Go version that is outside the builder's requirement (e.g., by using information in internal/goversion package or similar)

Then coordinator can print a warning about it when that builder is explicitly requested as a slowbot.

See #41829 for motivation.

/cc @ianlancetaylor @golang/release @cagedmantis @toothrot

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants