Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"golang.org/x/crypto/acme/autocert" error #42203

Closed
kuokuanyo opened this issue Oct 26, 2020 · 1 comment
Closed

"golang.org/x/crypto/acme/autocert" error #42203

kuokuanyo opened this issue Oct 26, 2020 · 1 comment

Comments

@kuokuanyo
Copy link

@kuokuanyo kuokuanyo commented Oct 26, 2020

What version of Go are you using (go version)?

$ go version
go version go1.13.1 windows/amd64

Does this issue reproduce with the latest release?

yes

What operating system and processor architecture are you using (go env)?

go env Output
$ go env
set GO111MODULE=
set GOARCH=amd64
set GOBIN=
set GOCACHE=C:\Users\User\AppData\Local\go-build
set GOENV=C:\Users\User\AppData\Roaming\go\env
set GOEXE=.exe
set GOFLAGS=
set GOHOSTARCH=amd64
set GOHOSTOS=windows
set GONOPROXY=
set GONOSUMDB=
set GOOS=windows
set GOPATH=C:\Users\User\go\src
set GOPRIVATE=
set GOPROXY=https://proxy.golang.org,direct
set GOROOT=C:\Users\User\go
set GOSUMDB=sum.golang.org
set GOTMPDIR=
set GOTOOLDIR=C:\Users\User\go\pkg\tool\windows_amd64
set GCCGO=gccgo
set AR=ar
set CC=gcc
set CXX=g++
set CGO_ENABLED=1
set GOMOD=
set CGO_CFLAGS=-g -O2
set CGO_CPPFLAGS=
set CGO_CXXFLAGS=-g -O2
set CGO_FFLAGS=-g -O2
set CGO_LDFLAGS=-g -O2
set PKG_CONFIG=pkg-config
set GOGCCFLAGS=-m64 -mthreads -fmessage-length=0 -fdebug-prefix-map=C:\Users\User\AppData\Local\Temp\go-build854140990=/tmp/go-build -gno-record-gcc-switches

What did you do?

When I use the "golang.org/x/crypto/acme/autocert" package in go and call http.Serve (autocert.NewListener("www.hilive.com.tw"), r) to use https for our domain Credentials, when I use this syntax and then centos to enable the service, it happens continuously" 2020/10/23 09:17:10 http: TLS handshake error from 117.135.87.191:5481: acme/autocert: HostWhitelist is not configured "tw .trojan.scloudlab.xyz". Such an error, where did the problem occur?

image
image

What did you expect to see?

"Http: TLS handshake error from 58.247.22.169:14692: acme/autocert: host "tw.trojan.scloudlab.xyz" not configured in HostWhitelist" error will no longer appear

What did you see instead?

@mvdan
Copy link
Member

@mvdan mvdan commented Oct 26, 2020

The Go project doesn't use the issue tracker for questions. See https://golang.org/wiki/Questions.

@mvdan mvdan closed this Oct 26, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.