Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/build: make >= go1.16 the bootstrap compiler for all builders #47914

Open
martisch opened this issue Aug 23, 2021 · 0 comments
Open

x/build: make >= go1.16 the bootstrap compiler for all builders #47914

martisch opened this issue Aug 23, 2021 · 0 comments

Comments

@martisch
Copy link
Contributor

@martisch martisch commented Aug 23, 2021

In Proposal #44505 it was accepted to make go1.16 the minimally required Go bootstrap version for go 1.18.

If we want to make the Go 1.18 release have cleanups that remove pre Go 1.16 work arounds in bootstrap and libraries we should upgrade the builders such that cleanup changes for Go 1.18 can still land while the tree is open.

I understand this is a large task as there are many builders so it might not work out in the end to have any changes that really need at least Go 1.16 as a bootstrap version in Go 1.18.

I made a cleanup CL for the sort package: https://go-review.googlesource.com/c/go/+/344351
Unfortunately all of the builders except linux-arm-aws (uses go1.15) failed as they seem to use an older (mostly go1.4) boostrap compiler.

/cc @dmitshur @cagedmantis

@martisch martisch added this to the Go1.18 milestone Aug 23, 2021
@toothrot toothrot added this to Planned in Go Release Team Aug 24, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants