Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/website/go.dev: /learn page does not suggest installing the latest version and also suitable for my operating system #48007

Open
sina-devel opened this issue Aug 27, 2021 · 2 comments

Comments

@sina-devel
Copy link

@sina-devel sina-devel commented Aug 27, 2021

What is the URL of the page with the issue?

Why https://go.dev/learn does not suggest installing the latest version and also suitable for my operating system ?

What is your user agent?

Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Screenshot

image

What did you expect to see?

Go v1.17 installation suggestion for linux

What did you see instead?

Go v1.15 installation suggestion for windows

@gopherbot gopherbot added this to the Unreleased milestone Aug 27, 2021
@sina-devel sina-devel changed the title x/website: Why https://go.dev/learn does not suggest installing the latest version x/website: Why https://go.dev/learn does not suggest installing the latest version and also not for my operating system Aug 27, 2021
@sina-devel sina-devel changed the title x/website: Why https://go.dev/learn does not suggest installing the latest version and also not for my operating system x/website: Why https://go.dev/learn does not suggest installing the latest version and also suitable for my operating system Aug 27, 2021
@dmitshur dmitshur changed the title x/website: Why https://go.dev/learn does not suggest installing the latest version and also suitable for my operating system x/website/go.dev: /learn page does not suggest installing the latest version and also suitable for my operating system Aug 27, 2021
@dmitshur
Copy link
Contributor

@dmitshur dmitshur commented Aug 27, 2021

It's likely Go 1.15 was shown because a frontend fetch failed, or JavaScript execution is disabled. The relevant code is:

async function getLatestVersion() {
    let version = 'go1.15'; // fallback version if fetch fails

Loading

@sina-devel
Copy link
Author

@sina-devel sina-devel commented Aug 28, 2021

It's likely Go 1.15 was shown because a frontend fetch failed, or JavaScript execution is disabled. The relevant code is:

async function getLatestVersion() {
    let version = 'go1.15'; // fallback version if fetch fails

Thanks, I think this is because golang.org has been banned by Google for Iran, but by changing the ip, it only shows the latest version correctly and not the operating system

Loading

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants