Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cmd/api: API check failing with "go tool api: signal: killed", "exit status 1" on linux-ppc64le-buildlet, linux-ppc64le-power9osu #54269

Closed
dmitshur opened this issue Aug 4, 2022 · 2 comments
Labels
NeedsInvestigation
Milestone

Comments

@dmitshur
Copy link
Contributor

@dmitshur dmitshur commented Aug 4, 2022

As of CL 420902 ("cmd/dist: require Go 1.17 for building Go" for #44505), API check fails on these two builders with:

##### API check
Error running API checker: exit status 1
go tool api: signal: killed
exit status 1
2022/08/04 21:17:55 Failed: exit status 1
go tool dist: FAILED

CC @rsc, @golang/ppc64.

@dmitshur dmitshur added the NeedsInvestigation label Aug 4, 2022
@dmitshur dmitshur added this to the Go1.20 milestone Aug 4, 2022
@pmur
Copy link
Contributor

@pmur pmur commented Aug 4, 2022

I suspect this is related to the change to download the bootstrap compiler inside the container. I also opened #54267.

If so, the containers likely need the memory limit bumped to compensate, or maybe the limit can be removed?

@gopherbot
Copy link

@gopherbot gopherbot commented Aug 5, 2022

Change https://go.dev/cl/421694 mentions this issue: env/linux-ppc64le/osuosl: greatly increase container ram limits

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
NeedsInvestigation
Projects
None yet
Development

No branches or pull requests

3 participants