Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cmd/go: TestScript failures #64568

Closed
gopherbot opened this issue Dec 5, 2023 · 2 comments
Closed

cmd/go: TestScript failures #64568

gopherbot opened this issue Dec 5, 2023 · 2 comments
Labels
NeedsInvestigation Someone must examine and confirm this is a valid issue and not a duplicate of an existing one.

Comments

@gopherbot
Copy link
Contributor

#!watchflakes
default <- pkg == "cmd/go" && test == "TestScript"

Issue created automatically to collect these failures.

Example (log):

vcs-test.golang.org rerouted to http://127.0.0.1:46277
https://vcs-test.golang.org rerouted to https://127.0.0.1:39017
go test proxy running at GOPROXY=http://127.0.0.1:34197/mod
2023/12/05 21:19:57 http: TLS handshake error from 127.0.0.1:58570: EOF
2023/12/05 21:19:59 http: TLS handshake error from 127.0.0.1:58734: read tcp 127.0.0.1:39017->127.0.0.1:58734: read: connection reset by peer
2023/12/05 21:19:59 http: TLS handshake error from 127.0.0.1:58702: read tcp 127.0.0.1:39017->127.0.0.1:58702: read: connection reset by peer
2023/12/05 21:19:59 http: TLS handshake error from 127.0.0.1:58720: read tcp 127.0.0.1:39017->127.0.0.1:58720: read: connection reset by peer
2023/12/05 21:20:06 http: TLS handshake error from 127.0.0.1:58872: read tcp 127.0.0.1:39017->127.0.0.1:58872: read: connection reset by peer
--- FAIL: TestScript (0.06s)
    --- FAIL: TestScript/mod_invalid_version (34.61s)
...
            	fatal: unable to access 'https://github.com/pierrec/lz4/': Could not resolve host: github.com
            go: github.com/pierrec/lz4@v2.0.9-0.20190209155647-9a39efadad3d+incompatible: invalid pseudo-version: git ls-remote -q origin in /tmp/workdir/tmp/cmd-go-test-1802302297/tmpdir4250466611/mod_invalid_version4109557425/gopath/pkg/mod/cache/vcs/036595127a116abca3f2bfd7bedafedb33d890c2b102d96361815966679432e7: exit status 128:
            	21:20:23.958695 http.c:756              == Info: Couldn't find host github.com in the .netrc file; using defaults
            	21:20:29.768745 http.c:756              == Info: Could not resolve host: github.com
            	@���@
            	21:20:29.768792 http.c:756              == Info: Closing connection 0
            	fatal: unable to access 'https://github.com/pierrec/lz4/': Could not resolve host: github.com
            [exit status 1]
            > stderr '^go: github.com/pierrec/lz4@v2.0.9-0.20190209155647-9a39efadad3d\+incompatible: invalid version: module contains a go.mod file, so module path must match major version \("github.com/pierrec/lz4/v2"\)$'
        script_test.go:156: FAIL: testdata/script/mod_invalid_version.txt:202: stderr '^go: github.com/pierrec/lz4@v2.0.9-0.20190209155647-9a39efadad3d\+incompatible: invalid version: module contains a go.mod file, so module path must match major version \("github.com/pierrec/lz4/v2"\)$': no match for `(?m)^go: github.com/pierrec/lz4@v2.0.9-0.20190209155647-9a39efadad3d\+incompatible: invalid version: module contains a go.mod file, so module path must match major version \("github.com/pierrec/lz4/v2"\)$` in stderr

watchflakes

@gopherbot gopherbot added the NeedsInvestigation Someone must examine and confirm this is a valid issue and not a duplicate of an existing one. label Dec 5, 2023
@gopherbot
Copy link
Contributor Author

Found new dashboard test flakes for:

#!watchflakes
default <- pkg == "cmd/go" && test == "TestScript"
2023-12-05 20:14 linux-arm64-longtest go@c915215a cmd/go.TestScript (log)
vcs-test.golang.org rerouted to http://127.0.0.1:46277
https://vcs-test.golang.org rerouted to https://127.0.0.1:39017
go test proxy running at GOPROXY=http://127.0.0.1:34197/mod
2023/12/05 21:19:57 http: TLS handshake error from 127.0.0.1:58570: EOF
2023/12/05 21:19:59 http: TLS handshake error from 127.0.0.1:58734: read tcp 127.0.0.1:39017->127.0.0.1:58734: read: connection reset by peer
2023/12/05 21:19:59 http: TLS handshake error from 127.0.0.1:58702: read tcp 127.0.0.1:39017->127.0.0.1:58702: read: connection reset by peer
2023/12/05 21:19:59 http: TLS handshake error from 127.0.0.1:58720: read tcp 127.0.0.1:39017->127.0.0.1:58720: read: connection reset by peer
2023/12/05 21:20:06 http: TLS handshake error from 127.0.0.1:58872: read tcp 127.0.0.1:39017->127.0.0.1:58872: read: connection reset by peer
--- FAIL: TestScript (0.06s)
    --- FAIL: TestScript/mod_invalid_version (34.61s)
...
            	fatal: unable to access 'https://github.com/pierrec/lz4/': Could not resolve host: github.com
            go: github.com/pierrec/lz4@v2.0.9-0.20190209155647-9a39efadad3d+incompatible: invalid pseudo-version: git ls-remote -q origin in /tmp/workdir/tmp/cmd-go-test-1802302297/tmpdir4250466611/mod_invalid_version4109557425/gopath/pkg/mod/cache/vcs/036595127a116abca3f2bfd7bedafedb33d890c2b102d96361815966679432e7: exit status 128:
            	21:20:23.958695 http.c:756              == Info: Couldn't find host github.com in the .netrc file; using defaults
            	21:20:29.768745 http.c:756              == Info: Could not resolve host: github.com
            	@���@
            	21:20:29.768792 http.c:756              == Info: Closing connection 0
            	fatal: unable to access 'https://github.com/pierrec/lz4/': Could not resolve host: github.com
            [exit status 1]
            > stderr '^go: github.com/pierrec/lz4@v2.0.9-0.20190209155647-9a39efadad3d\+incompatible: invalid version: module contains a go.mod file, so module path must match major version \("github.com/pierrec/lz4/v2"\)$'
        script_test.go:156: FAIL: testdata/script/mod_invalid_version.txt:202: stderr '^go: github.com/pierrec/lz4@v2.0.9-0.20190209155647-9a39efadad3d\+incompatible: invalid version: module contains a go.mod file, so module path must match major version \("github.com/pierrec/lz4/v2"\)$': no match for `(?m)^go: github.com/pierrec/lz4@v2.0.9-0.20190209155647-9a39efadad3d\+incompatible: invalid version: module contains a go.mod file, so module path must match major version \("github.com/pierrec/lz4/v2"\)$` in stderr

watchflakes

@bcmills
Copy link
Contributor

bcmills commented Dec 6, 2023

Duplicate of #55164

@bcmills bcmills marked this as a duplicate of #55164 Dec 6, 2023
@bcmills bcmills closed this as not planned Won't fix, can't repro, duplicate, stale Dec 6, 2023
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
NeedsInvestigation Someone must examine and confirm this is a valid issue and not a duplicate of an existing one.
Projects
None yet
Development

No branches or pull requests

2 participants