Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cmd/go: TestScript/mod_download_exec_toolchain failures #66905

Open
gopherbot opened this issue Apr 18, 2024 · 2 comments
Open

cmd/go: TestScript/mod_download_exec_toolchain failures #66905

gopherbot opened this issue Apr 18, 2024 · 2 comments
Labels
NeedsInvestigation Someone must examine and confirm this is a valid issue and not a duplicate of an existing one.

Comments

@gopherbot
Copy link

#!watchflakes
default <- pkg == "cmd/go" && test == "TestScript/mod_download_exec_toolchain"

Issue created automatically to collect these failures.

Example (log):

=== RUN   TestScript/mod_download_exec_toolchain
=== PAUSE TestScript/mod_download_exec_toolchain
=== CONT  TestScript/mod_download_exec_toolchain
    script_test.go:136: 2024-04-15T17:59:10Z
    script_test.go:138: $WORK=/Users/swarming/.swarming/w/ir/x/t/cmd-go-test-2698912352/tmpdir2560663496/mod_download_exec_toolchain1377329381
    script_test.go:160: 
        PATH=/Users/swarming/.swarming/w/ir/x/t/cmd-go-test-2698912352/tmpdir2560663496/testbin:/Users/swarming/.swarming/w/ir/x/w/goroot/bin:/Users/swarming/.swarming/w/ir/x/w/goroot/bin:/Users/swarming/.swarming/w/ir/x/w/goroot/bin:/Users/swarming/.swarming/w/ir/cache/tools/bin:/Users/swarming/.swarming/w/ir/bbagent_utility_packages:/Users/swarming/.swarming/w/ir/bbagent_utility_packages/bin:/Users/swarming/.swarming/w/ir/cipd_bin_packages:/Users/swarming/.swarming/w/ir/cipd_bin_packages/bin:/Users/swarming/.swarming/w/ir/cipd_bin_packages/cpython3:/Users/swarming/.swarming/w/ir/cipd_bin_packages/cpython3/bin:/Users/swarming/.swarming/w/ir/cache/cipd_client:/Users/swarming/.swarming/w/ir/cache/cipd_client/bin:/Users/swarming/.swarming/cipd_cache/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
        HOME=/no-home
        CCACHE_DISABLE=1
        GOARCH=amd64
...
        > stderr '^go: rsc.io/needall@v0.0.1 requires go >= 1.23; switching to go1.23.9$'
        matched: go: rsc.io/needall@v0.0.1 requires go >= 1.23; switching to go1.23.9
        > ! stderr '\(running'
        # GOTOOLCHAIN=min+auto should run the newer toolchain (0.045s)
        > env GOTOOLCHAIN=go1.21+auto
        > go mod download rsc.io/needgo121@latest rsc.io/needgo122@latest rsc.io/needgo123@latest rsc.io/needall@latest
        [stderr]
        go: rsc.io/needall@v0.0.1 requires go >= 1.23; switching to go1.23.9
    script_test.go:160: FAIL: testdata/script/mod_download_exec_toolchain.txt:19: go mod download rsc.io/needgo121@latest rsc.io/needgo122@latest rsc.io/needgo123@latest rsc.io/needall@latest: signal: illegal instruction
--- FAIL: TestScript/mod_download_exec_toolchain (0.21s)

watchflakes

@gopherbot gopherbot added the NeedsInvestigation Someone must examine and confirm this is a valid issue and not a duplicate of an existing one. label Apr 18, 2024
@gopherbot
Copy link
Author

Found new dashboard test flakes for:

#!watchflakes
default <- pkg == "cmd/go" && test == "TestScript/mod_download_exec_toolchain"
2024-04-15 17:44 gotip-darwin-amd64_11 go@b107d95b cmd/go.TestScript/mod_download_exec_toolchain (log)
=== RUN   TestScript/mod_download_exec_toolchain
=== PAUSE TestScript/mod_download_exec_toolchain
=== CONT  TestScript/mod_download_exec_toolchain
    script_test.go:136: 2024-04-15T17:59:10Z
    script_test.go:138: $WORK=/Users/swarming/.swarming/w/ir/x/t/cmd-go-test-2698912352/tmpdir2560663496/mod_download_exec_toolchain1377329381
    script_test.go:160: 
        PATH=/Users/swarming/.swarming/w/ir/x/t/cmd-go-test-2698912352/tmpdir2560663496/testbin:/Users/swarming/.swarming/w/ir/x/w/goroot/bin:/Users/swarming/.swarming/w/ir/x/w/goroot/bin:/Users/swarming/.swarming/w/ir/x/w/goroot/bin:/Users/swarming/.swarming/w/ir/cache/tools/bin:/Users/swarming/.swarming/w/ir/bbagent_utility_packages:/Users/swarming/.swarming/w/ir/bbagent_utility_packages/bin:/Users/swarming/.swarming/w/ir/cipd_bin_packages:/Users/swarming/.swarming/w/ir/cipd_bin_packages/bin:/Users/swarming/.swarming/w/ir/cipd_bin_packages/cpython3:/Users/swarming/.swarming/w/ir/cipd_bin_packages/cpython3/bin:/Users/swarming/.swarming/w/ir/cache/cipd_client:/Users/swarming/.swarming/w/ir/cache/cipd_client/bin:/Users/swarming/.swarming/cipd_cache/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
        HOME=/no-home
        CCACHE_DISABLE=1
        GOARCH=amd64
...
        > stderr '^go: rsc.io/needall@v0.0.1 requires go >= 1.23; switching to go1.23.9$'
        matched: go: rsc.io/needall@v0.0.1 requires go >= 1.23; switching to go1.23.9
        > ! stderr '\(running'
        # GOTOOLCHAIN=min+auto should run the newer toolchain (0.045s)
        > env GOTOOLCHAIN=go1.21+auto
        > go mod download rsc.io/needgo121@latest rsc.io/needgo122@latest rsc.io/needgo123@latest rsc.io/needall@latest
        [stderr]
        go: rsc.io/needall@v0.0.1 requires go >= 1.23; switching to go1.23.9
    script_test.go:160: FAIL: testdata/script/mod_download_exec_toolchain.txt:19: go mod download rsc.io/needgo121@latest rsc.io/needgo122@latest rsc.io/needgo123@latest rsc.io/needall@latest: signal: illegal instruction
--- FAIL: TestScript/mod_download_exec_toolchain (0.21s)

watchflakes

@gopherbot
Copy link
Author

Found new dashboard test flakes for:

#!watchflakes
default <- pkg == "cmd/go" && test == "TestScript/mod_download_exec_toolchain"
2024-05-14 20:14 gotip-darwin-arm64_11 go@c7597a8d cmd/go.TestScript/mod_download_exec_toolchain (log)
=== RUN   TestScript/mod_download_exec_toolchain
=== PAUSE TestScript/mod_download_exec_toolchain
=== CONT  TestScript/mod_download_exec_toolchain
    script_test.go:135: 2024-05-14T21:04:02Z
    script_test.go:137: $WORK=/opt/s/w/ir/x/t/cmd-go-test-439889329/tmpdir2065694873/mod_download_exec_toolchain3864564816
    script_test.go:159: 
        PATH=/opt/s/w/ir/x/t/cmd-go-test-439889329/tmpdir2065694873/testbin:/opt/s/w/ir/x/w/goroot/bin:/opt/s/w/ir/x/w/goroot/bin:/opt/s/w/ir/x/w/goroot/bin:/opt/s/w/ir/cache/tools/bin:/opt/s/w/ir/bbagent_utility_packages:/opt/s/w/ir/bbagent_utility_packages/bin:/opt/s/w/ir/cipd_bin_packages:/opt/s/w/ir/cipd_bin_packages/bin:/opt/s/w/ir/cipd_bin_packages/cpython3:/opt/s/w/ir/cipd_bin_packages/cpython3/bin:/opt/s/w/ir/cache/cipd_client:/opt/s/w/ir/cache/cipd_client/bin:/opt/s/cipd_cache/bin:/opt/infra-tools:/opt/local/bin:/opt/local/sbin:/usr/local/sbin:/usr/local/git/bin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
        HOME=/no-home
        CCACHE_DISABLE=1
        GOARCH=arm64
...
        matched: go: rsc.io/needgo123@v0.0.1 requires go >= 1.23 (running go 1.21; GOTOOLCHAIN=go1.21)
        > ! stderr 'requires go >= 1.21' # that's us!
        # JSON output should be emitted exactly once,
        # and non-JSON output should go to stderr instead of stdout. (0.030s)
        > env GOTOOLCHAIN=auto
        > go mod download -json rsc.io/needgo121@latest rsc.io/needgo122@latest rsc.io/needgo123@latest rsc.io/needall@latest
        [stderr]
        go: rsc.io/needall@v0.0.1 requires go >= 1.23; switching to go1.23.9
    script_test.go:159: FAIL: testdata/script/mod_download_exec_toolchain.txt:37: go mod download -json rsc.io/needgo121@latest rsc.io/needgo122@latest rsc.io/needgo123@latest rsc.io/needall@latest: signal: illegal instruction
--- FAIL: TestScript/mod_download_exec_toolchain (0.29s)

watchflakes

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
NeedsInvestigation Someone must examine and confirm this is a valid issue and not a duplicate of an existing one.
Projects
Status: No status
Development

No branches or pull requests

1 participant