Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cmd/compile: don't use REP prefix for reverse-order copying on amd64, 386 #7681

Open
randall77 opened this issue Apr 1, 2014 · 2 comments

Comments

@randall77
Copy link
Contributor

commented Apr 1, 2014

REP prefixes have a high startup cost.  Most were eliminated with CL 81370046.  For
overlapping source/destinations when we have to copy in descending address order, they
are still used.  Fix that.
@ianlancetaylor

This comment has been minimized.

Copy link
Contributor

commented May 9, 2014

Comment 1:

Labels changed: added repo-main, release-go1.4.

@rsc

This comment has been minimized.

Copy link
Contributor

commented Sep 15, 2014

Comment 2:

Labels changed: added release-go1.5, removed release-go1.4.

Status changed to Accepted.

@bradfitz bradfitz modified the milestone: Go1.5 Dec 16, 2014

@bradfitz bradfitz removed the release-go1.5 label Dec 16, 2014

@rsc rsc removed accepted labels Apr 14, 2015

@rsc rsc modified the milestones: Unplanned, Go1.5 Apr 26, 2015

@rsc rsc changed the title cmd/6g, cmd/8g: don't use REP prefix for reverse-order copying cmd/compile: don't use REP prefix for reverse-order copying on amd64, 386 Jun 8, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.