Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Failed to build golangci-lint v1.17.1 when enable GO111MODULE #581

Open
liubog2008 opened this issue Jun 19, 2019 · 3 comments

Comments

Projects
None yet
3 participants
@liubog2008
Copy link

commented Jun 19, 2019

$ go build -v ./...
build github.com/golangci/golangci-lint/cmd/golangci-lint: cannot load github.com/go-critic/go-critic/checkers: zip for github.com/go-critic/go-critic@v0.0.0-20181204210945-1df300866540 has unexpected file github.com/go-critic/go-critic@v0.0.0-20190526074819-1df300866540/.gitignore

go version: go1.12.5 linux/amd64
golangci-lint version: v1.17.1

@fhs

This comment has been minimized.

Copy link

commented Jun 26, 2019

Go 1.13 gives a slightly better error:

$ GOPROXY=direct go get github.com/golangci/golangci-lint@latest
go get: github.com/golangci/golangci-lint@v1.17.1 requires
	github.com/go-critic/go-critic@v0.0.0-20181204210945-1df300866540: invalid pseudo-version: does not match version-control timestamp (2019-05-26T07:48:19Z)

pierrre added a commit to pierrre/golangci-lint that referenced this issue Jul 10, 2019

fix invalid dependencies
Some dependencies have invalid date.

Fixes golangci#581 golangci#595

@pierrre pierrre referenced a pull request that will close this issue Jul 10, 2019

Open

fix invalid dependencies #605

pierrre added a commit to pierrre/golangci-lint that referenced this issue Jul 10, 2019

fix invalid dependencies
Some dependencies have invalid date.

Fixes golangci#581 golangci#595
@pierrre

This comment has been minimized.

Copy link

commented Jul 11, 2019

I've submitted a PR that fixes the issue
#605

@liubog2008

This comment has been minimized.

Copy link
Author

commented Jul 12, 2019

I have fixed it long long time ago = = @pierrre See #583

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.