Building gs-collection fails when using JDK 1.8.0-ea #7

Closed
neomatrix369 opened this Issue Jul 17, 2013 · 0 comments

Projects

None yet

2 participants

@neomatrix369

As part of the Adopt OpenJDK project, we have been building Java opensource projects using the EA release of Java 8 (from http://www.oracle.com/technetwork/java/javase/downloads/ea-jsp-142245.html) and found the below response (see gist):

https://gist.github.com/neomatrix369/6017864

When the build is successful, as a bonus you can add the below image to any gs-collections assets - github readme or website:

https://java.net/downloads/adoptopenjdk/compat.svg

Have a look at a sample usage to see what I mean:
https://github.com/neomatrix369/RESTAPIUnifier/blob/master/README.md

-- Adopt OpenJDK volunteer.

@goldmansachs goldmansachs pushed a commit that referenced this issue Sep 11, 2013
@motlin motlin [GSCOLLECT-1054] Fix ambiguous reference to removeIf when compiling w…
…ith Java 1.8.0-ea. Fixes issue #7.

git-svn-id: svn+ssh://gscollections.svn.services.gs.com/svnroot/gscollections-svn/trunk@361 d5c9223b-1aff-41ac-aadd-f810b4a99ac4
9a1056d
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment