Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WIP Builds 3 #1574

Open
gonetz opened this Issue Sep 17, 2017 · 213 comments

Comments

Projects
None yet
@gonetz
Copy link
Owner

gonetz commented Sep 17, 2017

@olivieryuyu

This comment has been minimized.

Copy link

olivieryuyu commented Sep 17, 2017

I have a weird flickering in cruis exotica now with this build

@loganmc10

This comment has been minimized.

Copy link
Contributor

loganmc10 commented Sep 17, 2017

I don't have that issue (tested mupen64plus), maybe you need to clear your shader cache?

@theboy181

This comment has been minimized.

Copy link

theboy181 commented Sep 17, 2017

Confirmed working here too

@Frank-74

This comment has been minimized.

Copy link

Frank-74 commented Sep 17, 2017

No flickering here either. But there's lines around all 2d elements in all but native resolution.

@theboy181

This comment has been minimized.

Copy link

theboy181 commented Sep 17, 2017

I was getting lines in Native Res..

@olivieryuyu

This comment has been minimized.

Copy link

olivieryuyu commented Sep 17, 2017

actually it works, just an error from my side

@Tasosgemah

This comment has been minimized.

Copy link

Tasosgemah commented Sep 18, 2017

Thanks. Tested F-Zero X, i assume the recent fixes for it aren't implemented yet?

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Sep 24, 2017

Current master:
https://drive.google.com/file/d/0B0YqMPjGo3B2NnBzTzVWQVFFbWc/view?usp=sharing

F-Zero, optimized blending and other fixes.

@theboy181

This comment has been minimized.

Copy link

theboy181 commented Sep 24, 2017

other fixes like WS?

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Sep 24, 2017

Ops, I forgot about WS hack. I'll do it tomorrow, if my memory will not fail me.

@theboy181

This comment has been minimized.

Copy link

theboy181 commented Sep 24, 2017

No worries.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Sep 30, 2017

Current master + fix_sprite_size branch:
https://drive.google.com/file/d/0B0YqMPjGo3B2UjJ4aWNNS0ZHZGs/view?usp=sharing

Built with Visual Studio 2015

@olivieryuyu

This comment has been minimized.

Copy link

olivieryuyu commented Sep 30, 2017

great, a lot of tickets closed :)

@theboy181

This comment has been minimized.

Copy link

theboy181 commented Sep 30, 2017

@gonetz there seems to be an issue where the plugin locks up after changing settings and exiting the GUI.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Oct 8, 2017

@theboy181 Looks like switch to new QT version was not as smooth as it liked. I'll check it later.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Oct 8, 2017

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Oct 8, 2017

You also can download win32 builds for mupen64plus there:
https://ci.appveyor.com/project/gonetz/gliden64/history
New build automatically created after each push to git.

@theboy181

This comment has been minimized.

Copy link

theboy181 commented Oct 8, 2017

Still having issue with the emulator crashing on PJ64 when you play with the GUI settings.

@Frank-74

This comment has been minimized.

Copy link

Frank-74 commented Oct 8, 2017

I had to click restore defaults, even though they were set to defaults, to get rid of some bugs I had with Perfect Dark. Is there something different in the ini, that it needs re-writing?

I also have problem with tooltips taking a minute to disappear in my build with VS2015.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Oct 9, 2017

Please open separate tickets for GUI issues

@Papermanzero

This comment has been minimized.

Copy link

Papermanzero commented Oct 9, 2017

In general it is pretty simple: this is a WIP release issue thread not a bug issue thread. So open for every kind of bug or issue a seperate thread with a reference to the build. In this manner this release thread stays clean

@DonelBueno

This comment has been minimized.

Copy link

DonelBueno commented Oct 27, 2017

@gonetz Could you post the current master here? Pretty please xD

@Papermanzero

This comment has been minimized.

Copy link

Papermanzero commented Oct 28, 2017

@RugRats

This comment has been minimized.

Copy link

RugRats commented Oct 28, 2017

@DonelBueno https://drive.google.com/file/d/0B7uzNEsNOxQSbHJmNjZKbFFtZGs/view?usp=sharing (zilmar spec/Project64) , I'm not gonetz, but I used the wikipage they made and am able to compile my own GLideN64 versions. This is the current master.

@DonelBueno

This comment has been minimized.

Copy link

DonelBueno commented Oct 28, 2017

Thank you, @RugRats. I don't like installing tons of software just to compile a plugin build.

@Papermanzero: Yeah, I know there are automated builds for Mupen64 now, but I use Project64. Thanks anyway.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Oct 29, 2017

@RugRats Thanks :)

@theboy181 "Still having issue with the emulator crashing on PJ64 when you play with the GUI settings."
I tested current master with Project64 2.3 I run several games, changed plugins settings during gameplay and after game stopped - no problems at all. May be something is broken in later builds of Project64 ?

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Oct 29, 2017

@gonetz

This comment has been minimized.

@Kidboy17

This comment has been minimized.

Copy link

Kidboy17 commented Jan 13, 2019

Its broken when you have Render 2D enabled, as is Mario Tennis

Mario Tennis has had this issue since December #1940

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Jan 20, 2019

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Jan 27, 2019

Current master + S2DEX fixes:
https://drive.google.com/file/d/1cIVuK5Tn_PkRqY7jBEtigNMJBjPbZ7L3/view?usp=sharing

Added option to select background rendering method.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 3, 2019

Current master:
https://drive.google.com/file/d/1I4-rJToOFD1Y13-ohaQykbEr62-gRpeq/view?usp=sharing

S2DEX branch merged to master. Few fixes.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 4, 2019

Folks, please do not post feedback in that thread! It is already huge.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 4, 2019

@billkings95 the problem with particles is fixed with commit 78e98d8.
Please open new issue if the problem still exists.

@gizmo98 problem with sd hiryu logo is fixed with commit 039f818.
Please open new issue if the problem still exists.

Issues in 2D are not regressions. It is how Bg commands work with LLE and with new HLE implementation. See #1971 for more details. Quick hint: use "Render 2D elements in native resolution" or switch back to old-style one-piece Bg emulation. Please use #1971 to discuss it.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 4, 2019

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 5, 2019

Current master:
https://drive.google.com/file/d/1jJFRGoqeKWwqCcPBXG1YbdWGYehLcBqf/view?usp=sharing

Added fix for bilinear filtering by gizmo98. Please leave feedback for this fix in #1933.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 7, 2019

Current master:
https://drive.google.com/file/d/1MHORjBEnksS6jIykPr6CZB8BEpgtiPn1/view?usp=sharing

Update for the bilinear filtering fix:

  • removed "filtering with color bleeding" options
  • new option added -"remove halos".
    The fix itself is not touched, only config options.
@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 8, 2019

Current master:
https://drive.google.com/file/d/1_vqInZV4Xb9YNFkSZ7bKg2fcF8RQM-dL/view?usp=sharing

Fixed rendering texrects in native resolution.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 17, 2019

Current master:
https://drive.google.com/file/d/1LG-_khXKTUqe_-B2uv-3_YkSkvSe9oEq/view?usp=sharing

3-point texture filtering for mipmapped textures.

@DaRkL3AD3R

This comment has been minimized.

Copy link

DaRkL3AD3R commented Feb 18, 2019

Just tested 3-point texture filtering. Sadly seems still not implemented properly. Textures just appear bilinear filtered. No filtering artifacts present which are visible when using real hardware or pixel-accurate plugins. Also, now I am seeing missing triangles on certain objects like walls and floors.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 18, 2019

@DaRkL3AD3R Please open new issue if 3-point texture filtering does not work right, with screen shots of what is wrong and how it should be. This thread is for WIP builds links, not for fedback.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Feb 24, 2019

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Mar 3, 2019

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Mar 11, 2019

@thekarter104

This comment has been minimized.

Copy link

thekarter104 commented Mar 14, 2019

Hello.

I have an error when I try to go to fullscreen with GlideN64:
"Failed to change display mode."

I tried different versions of GlideN64 including the public release 3.0 one.
How do I solve the issue?

On Jabo, I can go to fullscreen no problem, so this means it's possible to go fullscreen on my PC, so why GlideN64 can't?
I have a GTX GEForce 660Ti.

Thanks.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Mar 15, 2019

@thekarter104 please open new ticket for your problem. This thread is for WIP builds links, not for discussion.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Mar 24, 2019

Current master:
https://drive.google.com/file/d/1Np1fkWGjbrLXiOQqaaaSaDtzUk-Sx5UR/view?usp=sharing
I consider this build as Release Candidate 1. I fixed (almost) all regressions and currently I'm testing all games. This is a large work. I checked games from 0007 to M*. Please help me. I'd like to make regressions-free release.

Also I prepared build of experimental "Threaded OpenGL API calls" by fzurita : #2014 :
https://drive.google.com/file/d/1v43nesPE7vInmuzCG4q5HZ97sOZCgScW/view?usp=sharing
please give it a try and leave feedback at #2014.

@dezraj

This comment has been minimized.

Copy link

dezraj commented Mar 24, 2019

Gonetz, just a suggestion: could you add a comment balloon for FXAA, so that the layman users like me know the difference between using this anti aliasing option instead of the standard anti aliasing slider? Thank you so much for your hard work.

@gonetz

This comment has been minimized.

Copy link
Owner Author

gonetz commented Mar 25, 2019

Good point. I'll add tooltips for FXAA and MSAA.

@fzurita

This comment has been minimized.

Copy link
Contributor

fzurita commented Mar 25, 2019

I would like to point out that you mainly want to try the threaded version if you have performance issues with GLideN64.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.