New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Keymap Changed to JP on US Keyboard Environment #160

Closed
GoogleCodeExporter opened this Issue Apr 22, 2015 · 5 comments

Comments

Projects
None yet
1 participant
@GoogleCodeExporter

GoogleCodeExporter commented Apr 22, 2015

What steps will reproduce the problem?

I'm using US keyboard and the system identifies it when mozc is not active. 
Once mozc is activated, Keyboard layout is changed to JP. For example, when I 
hit '[' key, then the outcome is '@' in mozc, which '@' key exists on JP 
keyboard where '[' key exists on US keyboard. Of course, I see same results for 
all other keys.

What is the expected output?

Keyboard layout should be same as system default.

What do you see instead?

JP keyboard layout.

What version of the product are you using? On what operating system?

On Fedora 17 (beta), I'm using ibus-mozc package. Mozc version is 1.5.1053.102.

Please provide any additional information below.

Original issue reported on code.google.com by mikiya.o...@gmail.com on 28 May 2012 at 6:42

@GoogleCodeExporter

This comment has been minimized.

Show comment
Hide comment
@GoogleCodeExporter

GoogleCodeExporter Apr 22, 2015

Seems to be a duplication of Issue 159, which is introduced by IBus 1.4.99 
(IBus 1.5).

Original comment by yukawa@google.com on 28 May 2012 at 7:00

  • Added labels: OpSys-Linux, Priority-Low
  • Removed labels: Priority-Medium

GoogleCodeExporter commented Apr 22, 2015

Seems to be a duplication of Issue 159, which is introduced by IBus 1.4.99 
(IBus 1.5).

Original comment by yukawa@google.com on 28 May 2012 at 7:00

  • Added labels: OpSys-Linux, Priority-Low
  • Removed labels: Priority-Medium
@GoogleCodeExporter

This comment has been minimized.

Show comment
Hide comment
@GoogleCodeExporter

GoogleCodeExporter Apr 22, 2015

I've tested it with the following environment:
- Fedora 17 i686
- ibus-mozc-1.5.1053.102-1.fc17.i686.rpm
- ibus-1.4.99.20120428-2.fc17.i686.rpm (The about dialog says its version is 
1.4.99.20120518 somehow)
and can reproduce the issue you reported.

I also verified that you can work around this issue as follows as I've 
commented in Issue 159.

1. Open IBus Preferences.
2. Remove "Japanese - Mozc" and "Japanese Keyboard" from the Input Method.
3. Open /usr/share/ibus/component/mozc.xml with your favorite editor.
4. Replace "<layout>jp</layout>" with "<layout>default</layout>" and save the 
file.
5. Open IBus Preferences again.
6. Add "Japanese - Mozc" again.

Thanks,

Original comment by yukawa@google.com on 30 May 2012 at 7:53

GoogleCodeExporter commented Apr 22, 2015

I've tested it with the following environment:
- Fedora 17 i686
- ibus-mozc-1.5.1053.102-1.fc17.i686.rpm
- ibus-1.4.99.20120428-2.fc17.i686.rpm (The about dialog says its version is 
1.4.99.20120518 somehow)
and can reproduce the issue you reported.

I also verified that you can work around this issue as follows as I've 
commented in Issue 159.

1. Open IBus Preferences.
2. Remove "Japanese - Mozc" and "Japanese Keyboard" from the Input Method.
3. Open /usr/share/ibus/component/mozc.xml with your favorite editor.
4. Replace "<layout>jp</layout>" with "<layout>default</layout>" and save the 
file.
5. Open IBus Preferences again.
6. Add "Japanese - Mozc" again.

Thanks,

Original comment by yukawa@google.com on 30 May 2012 at 7:53

@GoogleCodeExporter

This comment has been minimized.

Show comment
Hide comment
@GoogleCodeExporter

GoogleCodeExporter Apr 22, 2015

Thank you for your instruction. I've confirmed the problem has been fixed by 
your workaround. Please note that I had to restart IBus between step 4 and 5.

Cheers,

Original comment by mikiya.o...@gmail.com on 30 May 2012 at 8:05

GoogleCodeExporter commented Apr 22, 2015

Thank you for your instruction. I've confirmed the problem has been fixed by 
your workaround. Please note that I had to restart IBus between step 4 and 5.

Cheers,

Original comment by mikiya.o...@gmail.com on 30 May 2012 at 8:05

@GoogleCodeExporter

This comment has been minimized.

Show comment
Hide comment
@GoogleCodeExporter

GoogleCodeExporter Apr 22, 2015

Original comment by yukawa@google.com on 10 Dec 2012 at 4:33

  • Now blocking: #161

GoogleCodeExporter commented Apr 22, 2015

Original comment by yukawa@google.com on 10 Dec 2012 at 4:33

  • Now blocking: #161
@GoogleCodeExporter

This comment has been minimized.

Show comment
Hide comment
@GoogleCodeExporter

GoogleCodeExporter Apr 22, 2015

Added a patch in Issue 161.

Original comment by yukawa@google.com on 10 Dec 2012 at 4:34

  • Changed state: Fixed

GoogleCodeExporter commented Apr 22, 2015

Added a patch in Issue 161.

Original comment by yukawa@google.com on 10 Dec 2012 at 4:34

  • Changed state: Fixed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment