Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Disable PiP button when playing audio-only assets #1849

Closed
theodab opened this issue Mar 21, 2019 · 0 comments

Comments

Projects
None yet
3 participants
@theodab
Copy link
Member

commented Mar 21, 2019

When playing an audio-only asset, the Picture-in-Picture button on the UI shows up. Pressing the button, however, results in an error.
If the button doesn't work, we should just not show it.

Similarly, there are issues if you enter PiP mode while playing a valid asset, and then load an audio-only asset. The PiP window will stay open, and the player will continue to be greyed out, but the audio-only asset will be playing, and the PiP window and the player will no longer be presenting the same asset. We should probably leave PiP mode automatically, in that case.

@shaka-bot shaka-bot added this to the v2.5 milestone Mar 21, 2019

@michellezhuogg michellezhuogg self-assigned this Mar 29, 2019

@shaka-bot shaka-bot closed this in 59966e2 Mar 29, 2019

@shaka-bot shaka-bot added the archived label May 28, 2019

@google google locked and limited conversation to collaborators May 28, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.