Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

vm/qemu: audio initialization fails #250

Closed
stfpeak opened this issue Jun 26, 2017 · 4 comments

Comments

@stfpeak
Copy link

commented Jun 26, 2017

ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4292:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4292:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4292:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4771:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default
alsa: Could not initialize DAC
alsa: Failed to open default': alsa: Reason: No such file or directory audio: Failed to create voice adlib'
qemu-system-x86_64: Initialization of device adlib failed: Initializing audio voice failed

when I run syz-manager -config=my.cfg, the error comes. How to solve this problem?

@dvyukov

This comment has been minimized.

Copy link
Collaborator

commented Jun 26, 2017

@stfpeak

This comment has been minimized.

Copy link
Author

commented Jun 26, 2017

I have solved the problem, Thank you! @dvyukov

@dvyukov dvyukov changed the title ALSA lib error,Initializing audio voice failed vm/qemu: audio initialization fails Jun 26, 2017

@dvyukov

This comment has been minimized.

Copy link
Collaborator

commented Jun 26, 2017

Thanks for testing.

We probably need to make "qemu_args": "-enable-kvm" the default. And then let people who are interested in device testing to add the additional flags manually.
So I am keeping this issue to make the change.

@xairy

This comment has been minimized.

Copy link
Collaborator

commented Nov 24, 2017

This seems to be fixed.

@xairy xairy closed this Nov 24, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.