Skip to content
Permalink
main
Switch branches/tags
Go to file
Co-authored-by: release-please[bot] <55107282+release-please[bot]@users.noreply.github.com>
1 contributor

Users who have contributed to this file

Changelog

1.35.1 (2022-06-10)

Bug Fixes

  • deps: update dependency com.google.api-client:google-api-client to v1.35.0 (#2083) (fd53573)
  • deps: update dependency com.google.cloud:libraries-bom to v25.4.0 (#2084) (df02577)
  • deps: update dependency com.google.oauth-client:google-oauth-client-bom to v1.34.1 (#2088) (960e7be)

1.35.0 (2022-06-02)

Features

Bug Fixes

  • deps: update dependency com.google.api-client:google-api-client to v1.34.0 (#2038) (afea56f)
  • deps: update dependency com.google.api-client:google-api-client to v1.34.1 (#2058) (d1ddb69)
  • deps: update dependency com.google.api-client:google-api-client-android to v1.34.1 (#2059) (54a9a0c)
  • deps: update dependency com.google.api-client:google-api-client-appengine to v1.34.1 (#2061) (872ad59)
  • deps: update dependency com.google.api-client:google-api-client-assembly to v1.34.1 (#2062) (1a1d1b3)
  • deps: update dependency com.google.api-client:google-api-client-gson to v1.34.1 (#2064) (3d1a03a)
  • deps: update dependency com.google.api-client:google-api-client-jackson2 to v1.34.1 (#2065) (3502186)
  • deps: update dependency com.google.api-client:google-api-client-java6 to v1.34.1 (#2066) (705e865)
  • deps: update dependency com.google.api-client:google-api-client-protobuf to v1.34.1 (#2068) (ecedb5b)
  • deps: update dependency com.google.api-client:google-api-client-servlet to v1.34.1 (#2070) (15540fe)
  • deps: update dependency com.google.api-client:google-api-client-xml to v1.34.1 (#2071) (050a269)
  • deps: update dependency com.google.appengine:appengine-api-1.0-sdk to v2.0.5 (#2072) (526e103)
  • deps: update dependency com.google.cloud:libraries-bom to v25.2.0 (#2050) (6c48f89)
  • deps: update dependency com.google.cloud:libraries-bom to v25.3.0 (#2073) (11dc2bb)
  • deps: update dependency com.google.oauth-client:google-oauth-client-bom to v1.33.3 (#2041) (be65181)
  • deps: update dependency com.google.oauth-client:google-oauth-client-bom to v1.34.0 (#2081) (8684064)
  • use verifyPayload instead of verify to disable duplicate signature check (#2080) (003ca44)

1.34.0 (2022-04-12)

Features

  • deprecate OOB auth flow in GooglePromptReceiver (#2034) (334d8d6)

Bug Fixes

  • deps: update dependency com.google.api-client:google-api-client to v1.33.4 (#2022) (582bde1)
  • deps: update dependency com.google.cloud:libraries-bom to v25.1.0 (#2025) (ba36a44)
  • deps: update dependency com.google.oauth-client:google-oauth-client-bom to v1.33.2 (#2033) (fed93e3)

Dependencies

1.33.4 (2022-03-28)

Dependencies

  • update dependency org.sonatype.plugins:nexus-staging-maven-plugin to v1.6.12 (#2019) (f1e0909)

1.33.3 (2022-03-25)

Bug Fixes

  • deps: update dependency com.google.api-client:google-api-client to v1.33.2 (#1985) (191850a)
  • deps: update dependency com.google.appengine:appengine-api-1.0-sdk to v2.0.4 (#2010) (b4c64a0)
  • deps: update dependency com.google.cloud:libraries-bom to v24.3.0 (#1987) (1620e8f)
  • deps: update dependency com.google.cloud:libraries-bom to v24.4.0 (#2007) (cba8dd2)
  • deps: update dependency com.google.cloud:libraries-bom to v25 (#2014) (43bd4a1)
  • deps: update dependency com.google.guava:guava to v31.1-jre (#2004) (eac0e77)
  • deps: update dependency com.google.oauth-client:google-oauth-client-bom to v1.33.1 (#1986) (b8376f1)

1.33.2 (2022-02-08)

Dependencies

1.33.1 (2022-01-21)

Bug Fixes

1.33.0 (2022-01-06)

Features

Bug Fixes

Dependencies

  • update dependency com.google.protobuf:protobuf-bom to v3.19.2 (98b5898)
  • update project.http.version to v1.41.0 (#1944) (98b5898)

1.32.2 (2021-10-14)

Dependencies

  • update dependency com.google.guava:guava to v31 (#1894) (aba6059)

1.32.1 (2021-06-24)

Bug Fixes

Dependencies

  • don't use sp versions in the regular release (#1840) (94cde71)

1.32.0 (2021-06-22)

Features

Bug Fixes

  • add reason field to Details in GoogleJsonErrorObject (#1831) (5e92b4c)

1.31.5 (2021-05-10)

Bug Fixes

  • release scripts from issuing overlapping phases (#1769) (3174ff9)
  • remove deprecated parent pom (#1785) (5da3355)
  • update GoogleJsonError object to accomodate all fields in Invalid parameter exception (#1783) (94c4570)

1.31.4 (2021-04-09)

Bug Fixes

  • re-encode public keys from google.jks into p12 format for android (#1738) (83f3702)
  • wrap BatchRequest InputStream with BufferedInputStream (#1749) (07346d8)

Dependencies

1.31.3 (2021-03-01)

Dependencies

1.31.2 (2021-01-14)

Bug Fixes

Documentation

  • Update the documentation link for GoogleCredential from deprecated version to newer version (#1652) (98db6ca)

Dependencies

1.31.1 (2020-11-16)

Bug Fixes

1.31.0 (2020-11-10)

Features

  • add GoogleApacheHttpTransport that uses the v2 ApacheHttpTransport implementation (#1568) (d0dbca7)
  • add mtls support to GoogleNetHttpTransport and GoogleApacheHttpTransport (#1619) (1d8304c)

Dependencies

  • update dependency com.google.appengine:appengine-api-1.0-sdk to v1.9.83 (#1622) (10bb904)
  • update dependency com.google.oauth-client:google-oauth-client-bom to v1.31.2 (#1623) (5942561)
  • update google-http-client to v1.38.0 (#1620) (bb63ded)

1.30.11 (2020-10-13)

Dependencies

  • update dependency com.google.appengine:appengine-api-1.0-sdk to v1.9.82 (#1518) (d77e5fa)
  • update dependency com.google.oauth-client:google-oauth-client-bom to v1.31.1 (#1599) (73f3a6d)
  • update dependency com.google.protobuf:protobuf-java to v3.13.0 (#1558) (27b0359)
  • update dependency commons-codec:commons-codec to v1.15 (#1574) (e453cdb)
  • update google-http-client to v1.37.0 (#1598) (6504e79)

1.30.10 (2020-07-08)

Bug Fixes

Dependencies

Documentation

  • removes reference to deprecated service (Google+) (#1530) (b257207)

1.30.9 (2020-02-18)

Bug Fixes

  • use embedded Proguard configuration instead of compile-time annotation (#1491) (8a59ed0), closes #1467 #1489

1.30.8 (2020-01-31)

Bug Fixes

Dependencies

1.30.7 (2019-12-17)

Bug Fixes

  • update GoogleUtils#getVersion() to use stable logic (#1452) (744839f)

Dependencies

  • update dependency com.google.oauth-client:google-oauth-client-bom to v1.30.5 (#1453) (b32a7d9)

1.30.6 (2019-12-03)

Bug Fixes

Documentation

Dependencies

  • remove jackson-core-asl (#1414) (8e08249)
  • update dependency com.google.protobuf:protobuf-java to v3.11.0 (#1431) (c4be24d)
  • update dependency com.google.protobuf:protobuf-java to v3.11.1 (#1436) (c1eaa85)
  • update guava to 28.1-android (#1410) (1d37f32)

1.30.5 (2019-10-24)

Bug Fixes

  • add details to GoogleJsonResponseExceptions created with GoogleJsonResponseExceptionFactoryTesting (#1395) (1ffdba6)
  • specify Metadata-Flavor for metadata requests (#1397) (d3dcfe9)

Dependencies

  • update dependency com.google.oauth-client:google-oauth-client-bom to v1.30.4 (#1401) (502cf1d)

Documentation

1.30.4 (2019-09-20)

Dependencies

  • update dependency com.google.oauth-client:google-oauth-client-bom to v1.30.3 (#1386) (3a9ba9a)
  • update dependency com.google.protobuf:protobuf-java to v3.10.0 (#1379) (309f8d4)
  • update google-http-client to v1.32.1 (#1384) (859570a)