Skip to content
Permalink
Browse files

Release google-api-java-client v1.30.0 (#1327)

* Release v1.30.0

* Annotating new features with `since` javadoc
  • Loading branch information...
chingor13 committed Jun 18, 2019
1 parent 6000d9f commit d0e16fd500821323ae1c2368a5b5e0681c5e1fde
@@ -197,7 +197,7 @@ To use Maven, add the following lines to your pom.xml file:
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client</artifactId>
<version>1.29.0</version>
<version>1.30.0</version>
</dependency>
</dependencies>
</project>
@@ -210,7 +210,7 @@ repositories {
mavenCentral()
}
dependencies {
compile 'com.google.api-client:google-api-client:1.29.0'
compile 'com.google.api-client:google-api-client:1.30.0'
}
```
[//]: # ({x-version-update-end})
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>google-api-client-android</artifactId>
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>google-api-client-appengine</artifactId>
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<groupId>com.google.api-client</groupId>
@@ -12,7 +12,7 @@ To use it in Maven, add the following to your `pom.xml`:
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-bom</artifactId>
<version>1.29.0</version>
<version>1.30.0</version>
<type>pom</type>
<scope>import</scope>
</dependency>
@@ -3,7 +3,7 @@
<modelVersion>4.0.0</modelVersion>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-bom</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<packaging>pom</packaging>

<name>Google API Client Library for Java BOM</name>
@@ -63,52 +63,52 @@
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-android</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-appengine</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-assembly</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-gson</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-jackson2</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-java6</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-protobuf</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-servlet</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
<dependency>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-xml</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
</dependency>
</dependencies>
</dependencyManagement>
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>google-api-client-gson</artifactId>
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>google-api-client-jackson2</artifactId>
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>google-api-client-java6</artifactId>
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>google-api-client-protobuf</artifactId>
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>google-api-client-servlet</artifactId>
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>google-api-client-xml</artifactId>
@@ -4,7 +4,7 @@
<parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>google-api-client</artifactId>
@@ -225,7 +225,11 @@ public final boolean getDisableGZipContent() {
return disableGZipContent;
}

/** Returns whether response should return raw input stream. */
/**
* Returns whether response should return raw input stream.
*
* @since 1.30
* */
public final boolean getReturnRawInputSteam() {
return returnRawInputStream;
}
@@ -260,6 +264,8 @@ public final boolean getReturnRawInputSteam() {
* chunks (see <a href="https://github.com/googleapis/google-api-java-client/issues/1009">#1009
* </a>). Setting this to true will make the response return the raw input stream.
* </p>
*
* @since 1.30
*/
public AbstractGoogleClientRequest<T> setReturnRawInputStream(boolean returnRawInputStream) {
this.returnRawInputStream = returnRawInputStream;
@@ -150,6 +150,8 @@ protected CommonGoogleClientRequestInitializer(Builder builder) {

/**
* Returns new builder.
*
* @since 1.30
*/
public static Builder newBuilder() {
return new Builder();
@@ -198,13 +200,15 @@ public final String getRequestReason() {
return requestReason;
}

/** Returns the user project of {@code null} */
/** Returns the user project or {@code null}. */
public final String getUserProject() {
return userProject;
}

/**
* Builder for {@code CommonGoogleClientRequestInitializer}.
*
* @since 1.30
*/
public static class Builder {
private String key;
@@ -137,6 +137,8 @@ protected void initializeJsonRequest(AbstractGoogleJsonClientRequest<?> request)

/**
* Builder for {@code CommonGoogleJsonClientRequestInitializer}.
*
* @since 1.30
*/
public static class Builder extends CommonGoogleClientRequestInitializer.Builder {
@Override
@@ -9,7 +9,7 @@
</parent>
<groupId>com.google.api-client</groupId>
<artifactId>google-api-client-parent</artifactId>
<version>1.29.1-SNAPSHOT</version><!-- {x-version-update:google-api-client:current} -->
<version>1.30.0</version><!-- {x-version-update:google-api-client:current} -->
<packaging>pom</packaging>
<name>Parent for the Google API Client Library for Java</name>

@@ -1,4 +1,4 @@
# Format:
# module:released-version:current-version

google-api-client:1.29.0:1.29.1-SNAPSHOT
google-api-client:1.30.0:1.30.0

0 comments on commit d0e16fd

Please sign in to comment.
You can’t perform that action at this time.