Skip to content
Permalink
Browse files

chore(deps)!: require 3.6+ (#961)

Removes 2.7 and 3.5 from the test suite and explicitly requires >= 3.6. Also adds tests for 3.9

Fixes #704 🦕
  • Loading branch information
busunkim96 committed Dec 9, 2020
1 parent 0bf565c commit 8325d24acaa2b2077acaaea26ea5fafb6dd856c5
Showing with 10 additions and 18 deletions.
  1. +3 −3 README.md
  2. +2 −6 noxfile.py
  3. +5 −9 setup.py
@@ -48,11 +48,11 @@ virtualenv <your-env>

## Supported Python Versions

Python 3.5, 3.6 and 3.7, and 3.8 are fully supported and tested. This library may work on later versions of 3, but we do not currently run tests against those versions
Python 3.6, 3.7, 3.8, and 3.9 are fully supported and tested. This library may work on later versions of 3, but we do not currently run tests against those versions.

## Deprecated Python Versions
## Unsupported Python Versions

Python == 2.7
Python < 3.6

## Third Party Libraries and Dependencies

@@ -18,6 +18,7 @@
import nox

test_dependencies = [
"django>=2.0.0",
"google-auth",
"google-auth-httplib2",
"mox",
@@ -46,7 +47,7 @@ def lint(session):
)


@nox.session(python=["2.7", "3.5", "3.6", "3.7", "3.8"])
@nox.session(python=["3.6", "3.7", "3.8", "3.9"])
@nox.parametrize(
"oauth2client",
[
@@ -59,11 +60,6 @@ def lint(session):
def unit(session, oauth2client):
session.install(*test_dependencies)
session.install(oauth2client)
if session.python < "3.0":
session.install("django<2.0.0")
else:
session.install("django>=2.0.0")

session.install('.')

# Run py.test against the unit tests.
@@ -21,11 +21,8 @@

import sys

if sys.version_info < (2, 7):
print("google-api-python-client requires python version >= 2.7.", file=sys.stderr)
sys.exit(1)
if (3, 1) <= sys.version_info < (3, 4):
print("google-api-python-client requires python3 version >= 3.4.", file=sys.stderr)
if sys.version_info < (3, 6):
print("google-api-python-client requires python3 version >= 3.6.", file=sys.stderr)
sys.exit(1)

import io
@@ -61,18 +58,17 @@
author_email="googleapis-packages@google.com",
url="https://github.com/googleapis/google-api-python-client/",
install_requires=install_requires,
python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*",
python_requires=">=3.6",
packages=packages,
package_data={},
license="Apache 2.0",
keywords="google api client",
classifiers=[
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"License :: OSI Approved :: Apache Software License",

0 comments on commit 8325d24

Please sign in to comment.