Skip to content
Permalink
Browse files
fix(deps): pin 'google-{api,cloud}-core', 'google-auth' to allow 2.x …
…versions (#1449)

Expand pins on library dependencies in preparation for these dependencies taking a new major version. See googleapis/google-cloud-python#10566.
  • Loading branch information
busunkim96 committed Jul 20, 2021
1 parent 0770807 commit 96d2bb04f99d57f0fff2b81e8f4e792782deb712
Showing with 8 additions and 2 deletions.
  1. +8 −2 setup.py
@@ -33,9 +33,15 @@

install_requires = [
"httplib2>=0.15.0,<1dev",
"google-auth>=1.16.0,<2dev",
# NOTE: Maintainers, please do not require google-auth>=2.x.x
# Until this issue is closed
# https://github.com/googleapis/google-cloud-python/issues/10566
"google-auth>=1.16.0,<3.0.0dev",
"google-auth-httplib2>=0.1.0",
"google-api-core>=1.21.0,<2dev",
# NOTE: Maintainers, please do not require google-api-core>=2.x.x
# Until this issue is closed
# https://github.com/googleapis/google-cloud-python/issues/10566
"google-api-core>=1.21.0,<3.0.0dev",
"six>=1.13.0,<2dev",
"uritemplate>=3.0.0,<4dev",
]

0 comments on commit 96d2bb0

Please sign in to comment.