Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Java 5 compatibility checks #232

Closed
wonderfly opened this issue Jan 9, 2015 · 2 comments

Comments

@wonderfly
Copy link
Contributor

commented Jan 9, 2015

From yan...@google.com on June 24, 2013 12:11:58

Use the Animal Sniffer plugin to ensure we write code that is compatible with Java 5: http://mojo.codehaus.org/animal-sniffer-maven-plugin/ Use the Enforce Bytecode Version Plugin to ensure our dependencies are compatible with Java 5: http://mojo.codehaus.org/extra-enforcer-rules/enforceBytecodeVersion.html

Original issue: http://code.google.com/p/google-http-java-client/issues/detail?id=232

@wonderfly

This comment has been minimized.

Copy link
Contributor Author

commented Jan 9, 2015

From ngmic...@google.com on July 01, 2013 13:06:30

https://codereview.appspot.com/10679049/

Status: Started

@wonderfly wonderfly self-assigned this Jan 9, 2015

@wonderfly

This comment has been minimized.

Copy link
Contributor Author

commented Jan 9, 2015

From ngmic...@google.com on July 02, 2013 09:12:57

We added the Animal Sniffer plugin but not the Enforcer plugin. The Enforcer plugin crashes with a NullPointerException. This seems to be because we specify version numbers in instead of directly on the dependencies.

The following thread appears to be the issue we're facing as well: http://stackoverflow.com/questions/1017019/maven-assembly-plugin-fails-with-nullpointerexception Particularly the comment on the answer: http://stackoverflow.com/questions/1017019/maven-assembly-plugin-fails-with-nullpointerexception#comment826448_1017037 This will be tracked in a new issue: https://code.google.com/p/google-http-java-client/issues/detail?id=234

Status: Fixed

@wonderfly wonderfly closed this Jan 9, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.