Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

chore(deps): update gax.version to v1.52.0 #31

Closed

Conversation

renovate-bot
Copy link
Contributor

@renovate-bot renovate-bot commented Dec 13, 2019

This PR contains the following updates:

Package Update Change
com.google.api:gax-bom (source) minor 1.51.0 -> 1.52.0
com.google.api:gax-grpc (source) minor 1.51.0 -> 1.52.0

Release Notes

googleapis/gax-java

v1.52.0

Compare Source


Renovate configuration

馃搮 Schedule: At any time (no schedule defined).

馃殾 Automerge: Disabled by config. Please merge this manually once you are satisfied.

鈾伙笍 Rebasing: Whenever PR becomes conflicted, or if you modify the PR title to begin with "rebase!".

馃敃 Ignore: Close this PR and you won't be reminded about these updates again.


  • If you want to rebase/retry this PR, check this box

Newsflash: Renovate has joined WhiteSource, and is now free for all use. Learn more or view updated terms and privacy policies.

@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Dec 13, 2019
@googlebot googlebot added the cla: yes label Dec 13, 2019
@kokoro-team kokoro-team removed the kokoro:run label Dec 13, 2019
@codecov
Copy link

@codecov codecov bot commented Dec 13, 2019

Codecov Report

Merging #31 into master will decrease coverage by 0.05%.
The diff coverage is n/a.

Impacted file tree graph

@@             Coverage Diff              @@
##             master      #31      +/-   ##
============================================
- Coverage     77.36%   77.31%   -0.06%     
+ Complexity     1107     1106       -1     
============================================
  Files            73       73              
  Lines          5911     5893      -18     
  Branches        645      631      -14     
============================================
- Hits           4573     4556      -17     
+ Misses         1012     1011       -1     
  Partials        326      326
Impacted Files Coverage 螖 Complexity 螖
...com/google/cloud/bigquery/StandardSQLDataType.java 73.68% <0%> (-1.32%) 7% <0%> (酶)
...m/google/cloud/bigquery/StandardSQLStructType.java 84.61% <0%> (-1.1%) 5% <0%> (酶)
...ava/com/google/cloud/bigquery/RoutineArgument.java 85.71% <0%> (-0.65%) 5% <0%> (酶)
...google/cloud/bigquery/ExternalTableDefinition.java 56.38% <0%> (-0.46%) 16% <0%> (酶)
...va/com/google/cloud/bigquery/StandardSQLField.java 90.47% <0%> (-0.44%) 7% <0%> (酶)
...java/com/google/cloud/bigquery/ViewDefinition.java 87.09% <0%> (-0.41%) 11% <0%> (酶)
...y/src/main/java/com/google/cloud/bigquery/Job.java 84.67% <0%> (-0.23%) 32% <0%> (-1%)
...google/cloud/bigquery/StandardTableDefinition.java 86.56% <0%> (-0.2%) 14% <0%> (酶)
...om/google/cloud/bigquery/BigtableColumnFamily.java 95.83% <0%> (-0.17%) 5% <0%> (酶)
...ogle/cloud/bigquery/WriteChannelConfiguration.java 86.05% <0%> (-0.07%) 44% <0%> (酶)
... and 6 more

Continue to review full report at Codecov.

Legend - Click here to learn more
螖 = absolute <relative> (impact), 酶 = not affected, ? = missing data
Powered by Codecov. Last update 43dc12c...3f2d43a. Read the comment docs.

@BenWhitehead
Copy link

@BenWhitehead BenWhitehead commented Dec 13, 2019

Kokoro - Test: Dependencies will be failing until the changes in #30 are merged.

stephaniewang526 added a commit to stephaniewang526/java-bigquery that referenced this issue Dec 18, 2019
All updates:

| Package | Update | Change |
|---|---|---|
| `com.google.auth:google-auth-library-oauth2-http` | minor | `0.18.0` -> `0.19.0` |
| `com.google.auto.value:auto-value` (jdk 1.8+) | minor | `1.6.6` -> `1.7` |
| `com.google.auto.value:auto-value-annotations` | minor | `1.6.6` -> `1.7` |
| [com.google.api:gax-bom](https://togithub.com/googleapis/gax-java) ([source](https://togithub.com/googleapis/gax-java)) | minor | `1.51.0` -> `1.52.0` |
| [com.google.api:gax-grpc](https://togithub.com/googleapis/gax-java) ([source](https://togithub.com/googleapis/gax-java)) | minor | `1.51.0` -> `1.52.0` |
| [com.google.cloud:google-cloud-core-grpc](https://togithub.com/googleapis/google-cloud-java/tree/master/google-cloud-clients/google-cloud-core-grpc) | minor | `1.91.3` -> `1.92.0` |
| [com.google.cloud:google-cloud-core](https://togithub.com/googleapis/google-cloud-java/tree/master/google-cloud-clients/google-cloud-core) | minor | `1.91.3` -> `1.92.0` |

**manually copied and merged from the following PRs**
* deps: update gax.version to v1.52.0 googleapis#31
* deps: update google.core.version to v1.92.0 googleapis#35
* deps: update dependency com.google.auth:google-auth-library-oauth2-http to v0.19.0 googleapis#30
@stephaniewang526
Copy link
Member

@stephaniewang526 stephaniewang526 commented Dec 18, 2019

superseded by #46

@forking-renovate
Copy link

@forking-renovate forking-renovate bot commented Dec 18, 2019

Renovate Ignore Notification

As this PR has been closed unmerged, Renovate will now ignore this update (1.52.0). You will still receive a PR once a newer version is released, so if you wish to permanently ignore this dependency, please add it to the ignoreDeps array of your renovate config.

If this PR was closed by mistake or you changed your mind, you can simply rename this PR and you will soon get a fresh replacement PR opened.

@renovate-bot renovate-bot deleted the renovate/gax.version branch Dec 18, 2019
stephaniewang526 added a commit that referenced this issue Dec 18, 2019
* deps: update dependencies

All updates:

| Package | Update | Change |
|---|---|---|
| `com.google.auth:google-auth-library-oauth2-http` | minor | `0.18.0` -> `0.19.0` |
| `com.google.auto.value:auto-value` (jdk 1.8+) | minor | `1.6.6` -> `1.7` |
| `com.google.auto.value:auto-value-annotations` | minor | `1.6.6` -> `1.7` |
| [com.google.api:gax-bom](https://togithub.com/googleapis/gax-java) ([source](https://togithub.com/googleapis/gax-java)) | minor | `1.51.0` -> `1.52.0` |
| [com.google.api:gax-grpc](https://togithub.com/googleapis/gax-java) ([source](https://togithub.com/googleapis/gax-java)) | minor | `1.51.0` -> `1.52.0` |
| [com.google.cloud:google-cloud-core-grpc](https://togithub.com/googleapis/google-cloud-java/tree/master/google-cloud-clients/google-cloud-core-grpc) | minor | `1.91.3` -> `1.92.0` |
| [com.google.cloud:google-cloud-core](https://togithub.com/googleapis/google-cloud-java/tree/master/google-cloud-clients/google-cloud-core) | minor | `1.91.3` -> `1.92.0` |

**manually copied and merged from the following PRs**
* deps: update gax.version to v1.52.0 #31
* deps: update google.core.version to v1.92.0 #35
* deps: update dependency com.google.auth:google-auth-library-oauth2-http to v0.19.0 #30

* deps: fix DEFAULT_CHUNK_SIZE in response to the same change in java-core 1.92.0
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
cla: yes
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

5 participants