Skip to content
Permalink
7b728c35bf
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
932 lines (538 sloc) 87.3 KB

Changelog

2.8.1 (2022-06-27)

Dependencies

  • update dependency com.google.protobuf:protobuf-bom to v3.21.2 (#851) (c0f09f0)

2.8.0 (2022-06-21)

Features

  • add build scripts for native image testing in Java 17 (#1440) (#836) (8826d9b)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.35.1 (#843) (9ffe0c5)
  • update dependency com.google.api:api-common to v2.2.1 (#844) (69dde56)
  • update dependency com.google.api:gax-bom to v2.18.2 (#849) (11764b0)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.9.0 (#846) (5dced6d)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.4.0 (#838) (b0a7afe)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.4.1 (#848) (8260997)
  • update dependency com.google.errorprone:error_prone_annotations to v2.14.0 (#839) (3459fb6)
  • update dependency com.google.http-client:google-http-client-bom to v1.42.0 (#845) (2d2c873)
  • update dependency com.google.protobuf:protobuf-bom to v3.21.0 (#840) (037da15)
  • update dependency com.google.protobuf:protobuf-bom to v3.21.1 (#841) (04b8862)
  • update dependency io.grpc:grpc-bom to v1.47.0 (#842) (40984e2)

2.7.1 (2022-05-19)

Dependencies

  • update dependency com.google.api:gax-bom to v2.18.1 (#833) (7541115)

2.7.0 (2022-05-18)

Features

  • java: remove native-image-support module (#820) (a53ef6d)
  • next release from main branch is 2.7.0 (#807) (5a2c608)

Bug Fixes

  • remove native-image-support module from version.txt (#822) (92e7efc)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.34.1 (#823) (71105c6)
  • update dependency com.google.api:api-common to v2.2.0 (#827) (05a02d6)
  • update dependency com.google.api:gax-bom to v2.17.0 (#826) (c90188e)
  • update dependency com.google.api:gax-bom to v2.18.0 (#829) (5537e7f)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.3.2 (#805) (493ac03)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.3.3 (#814) (e809baa)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.3.4 (#825) (5ce12ee)
  • update dependency com.google.auth:google-auth-library-bom to v1.7.0 (#828) (2abca2c)
  • update dependency com.google.cloud:native-image-support to v0.14.0 (#824) (997a34a)
  • update dependency com.google.errorprone:error_prone_annotations to v2.13.1 (#806) (9fc5811)
  • update dependency com.google.http-client:google-http-client-bom to v1.41.8 (#821) (c7e3d6e)
  • update dependency com.google.protobuf:protobuf-bom to v3.20.1 (#813) (a9c8c92)
  • update dependency io.grpc:grpc-bom to v1.46.0 (#815) (03c9bfe)
  • update opencensus.version to v0.31.1 (#819) (1800d3a)

2.6.1 (2022-04-14)

Dependencies

  • update dependency com.google.errorprone:error_prone_annotations to v2.13.0 (#802) (042b08e)

2.6.0 (2022-04-14)

Features

  • java: remove GoogleJsonClentFeature and OpenCensusFeature after relocation (#793) (2880112)
  • java: remove Netty Native Image configuration after relocation to gax (#771) (9ba04f9)
  • java: remove protobuf Native Image configuration (#784) (0bc8549)
  • remove native-image.properties settings after relocation (#794) (e24bfdd)
  • remove resource-config after relocation (#795) (87e2973)
  • remove substitutions after relocation to gax (#789) (29291e9)

Bug Fixes

  • java: register test class for reflection to fix native image test (#766) (6fe52c3)

Dependencies

  • revert protobuf to 3.19 and common-protos 2.8.3 (#798) (0f36a84)
  • update dependency com.google.api-client:google-api-client-bom to v1.34.0 (#800) (8430aee)
  • update dependency com.google.api:gax-bom to v2.16.0 (#785) (fd435b0)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.8.1 (#792) (4d201ac)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.8.2 (#796) (dc28a0f)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.3.0 (#783) (4ed5ba4)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.3.1 (#799) (fce5315)
  • update dependency com.google.errorprone:error_prone_annotations to v2.12.1 (#788) (4e71f68)
  • update dependency com.google.http-client:google-http-client-bom to v1.41.6 (#791) (fe006c6)
  • update dependency com.google.http-client:google-http-client-bom to v1.41.7 (#797) (570f8d5)
  • update dependency com.google.protobuf:protobuf-bom to v3.20.0 (#787) (19202bc)
  • update dependency io.grpc:grpc-bom to v1.45.1 (#780) (6e3bf35)

2.5.11 (2022-03-28)

Bug Fixes

  • java: Register Spanner classes for reflection to fix Native Image tests (#760) (257de0f)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.33.4 (#776) (1b6fb2a)
  • update dependency com.google.api:api-common to v2.1.5 (#768) (c76c332)
  • update dependency com.google.api:gax-bom to v2.13.0 (#774) (8075c54)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.8.0 (#770) (6809477)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.10 (#763) (9f2eb5f)
  • update dependency com.google.auth:google-auth-library-bom to v1.6.0 (#765) (2eb1924)
  • update dependency com.google.guava:guava to 31.1-jre (#772) (060adf3)
  • update dependency com.google.http-client:google-http-client-bom to v1.41.5 (#769) (999be7a)
  • update dependency org.threeten:threetenbp to v1.6.0 (#767) (9a4a438)

2.5.10 (2022-03-10)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.9 (#759) (9585d4e)

2.5.9 (2022-03-09)

Dependencies

  • update dependency io.grpc:grpc-bom to v1.45.0 (#756) (403b10a)

2.5.8 (2022-03-08)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.8 (#753) (6866b84)

2.5.7 (2022-03-08)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.7 (#748) (91cc595)

2.5.6 (2022-03-01)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.6 (#742) (474e56c)

2.5.5 (2022-02-28)

Bug Fixes

  • java: initialize spanner test environment class at build-time (#734) (684934e)
  • java: initialize TestTag at build time (#732) (a5f1dc2)

Dependencies

  • update actions/setup-java action to v3 (#739) (46322e3)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.7.4 (#728) (3b83bd7)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.4 (#729) (0759c2b)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.5 (#735) (cefbf97)
  • update dependency com.google.auth:google-auth-library-bom to v1.5.3 (#737) (a1cb8d8)
  • update dependency com.google.code.gson:gson to v2.9.0 (#727) (faf8a44)
  • update dependency com.google.http-client:google-http-client-bom to v1.41.4 (#730) (1975b61)
  • update dependency io.grpc:grpc-bom to v1.44.1 (#736) (4ca315c)

2.5.4 (2022-02-11)

Dependencies

  • update actions/github-script action to v6 (#724) (b8673d3)

2.5.3 (2022-02-10)

Dependencies

  • update dependency com.google.api:gax-bom to v2.12.2 (#719) (4de90d0)
  • update dependency com.google.http-client:google-http-client-bom to v1.41.3 (#720) (d2a5b4f)

2.5.2 (2022-02-09)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.3 (#716) (100e41e)

2.5.1 (2022-02-08)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.33.2 (#709) (de08f4e)
  • update dependency com.google.api:api-common to v2.1.4 (#712) (9cc49de)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.7.3 (#710) (a5f1991)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.2 (#705) (b8722b9)

2.5.0 (2022-02-02)

Features

Bug Fixes

  • java: Initialize AsyncSSLPrivateKeyMethod (a grpc netty class) at run-time (#702) (24146a3)

Dependencies

  • update dependency com.google.api:gax-bom to v2.12.0 (#698) (c10aab8)
  • update dependency com.google.protobuf:protobuf-bom to v3.19.4 (#699) (5d163f5)

2.4.0 (2022-01-28)

Features

  • java: Add native-image support classes to java-core module (#637) (154bc18)

Bug Fixes

  • java: initialize LoggerFactory at build time (#685) (eb3aba2)

Dependencies

  • java: update actions/github-script action to v5 (#1339) (#689) (eb462c7)
  • update dependency com.google.api-client:google-api-client-bom to v1.33.1 (#684) (9ff47e6)
  • update dependency com.google.api:api-common to v2.1.3 (#694) (684ae80)
  • update dependency com.google.api:gax-bom to v2.11.0 (#677) (1a578bd)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.7.2 (#695) (1085d2c)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.1 (#667) (b57ec04)
  • update dependency com.google.auth:google-auth-library-bom to v1.4.0 (#681) (3273b1e)
  • update dependency com.google.errorprone:error_prone_annotations to v2.11.0 (#687) (dc4d18d)
  • update dependency com.google.http-client:google-http-client-bom to v1.41.1 (#683) (45cb753)
  • update dependency com.google.http-client:google-http-client-bom to v1.41.2 (#696) (f4875c0)
  • update dependency com.google.protobuf:protobuf-bom to v3.19.3 (#674) (c54f997)
  • update dependency io.grpc:grpc-bom to v1.43.2 (#665) (752ba6e)
  • update dependency io.grpc:grpc-bom to v1.44.0 (#693) (ed85045)
  • update dependency org.easymock:easymock to v4 (#668) (c36e976)
  • update dependency org.graalvm.sdk:graal-sdk to v22 (#680) (0f535f8)
  • update graalvm.version to v21.3.1 (#679) (dfb305a)
  • update graalvm.version to v22.0.0.2 (#691) (780b734)
  • update opencensus.version to v0.30.0 (#646) (c2caaa7)
  • update opencensus.version to v0.31.0 (#692) (bdf7d4e)

2.3.5 (2022-01-06)

Dependencies

  • update dependency com.google.api:api-common to v2.1.2 (#661) (0a136d8)
  • update gax.version to v2.8.1 (#663) (7c09aa5)

2.3.4 (2022-01-06)

Bug Fixes

  • fixed compilation warnings from error prone (e6e7040)
  • java: add -ntp flag to native image testing command (#1299) (#643) (0f4c1db)
  • java: run Maven in plain console-friendly mode (#1301) (#652) (ab2fa93)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.33.0 (#658) (d417ebd)
  • update dependency com.google.api:gax-bom to v2.8.0 (#659) (91717ab)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.7.1 (#656) (ecfbdc1)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.2.0 (#645) (3926b54)
  • update dependency com.google.http-client:google-http-client-bom to v1.41.0 (#657) (41a5120)
  • update dependency com.google.protobuf:protobuf-bom to v3.19.2 (#655) (eb6c037)
  • update dependency io.grpc:grpc-bom to v1.43.1 (#647) (275b882)

2.3.3 (2021-12-02)

Dependencies

  • update dependency com.google.api:gax-bom to v2.7.1 (#640) (18e033b)

2.3.2 (2021-12-02)

Dependencies

  • update dependency com.google.api:api-common to v2.1.1 (#632) (b9bb47a)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.7.0 (#638) (74862a8)

2.3.1 (2021-11-15)

Dependencies

  • update dependency io.grpc:grpc-bom to v1.42.1 (#629) (85fcd99)

2.3.0 (2021-11-11)

Features

  • next release from main branch is 2.3.0 (#602) (34fa5f1)

Bug Fixes

Dependencies

  • update dependency com.google.api:api-common to v2.1.0 (#613) (62d6ab8)
  • update dependency com.google.api:gax-bom to v2.7.0 (#626) (4a1e965)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.1.7 (#604) (0d36d59)
  • update dependency com.google.auth:google-auth-library-bom to v1.2.2 (#610) (c5e33d8)
  • update dependency com.google.auth:google-auth-library-bom to v1.3.0 (#627) (f4403b2)
  • update dependency com.google.code.gson:gson to v2.8.9 (#615) (ec0e387)
  • update dependency com.google.errorprone:error_prone_annotations to v2.10.0 (#618) (21139a8)
  • update dependency com.google.protobuf:protobuf-bom to v3.19.1 (#609) (28e6333)
  • update dependency io.grpc:grpc-bom to v1.42.0 (#619) (da4cbd5)
  • update dependency org.threeten:threetenbp to v1.5.2 (#624) (91eec9d)

2.2.0 (2021-10-18)

Features

  • next release from main branch is 2.2.0 (#596) (cca72b8)

Dependencies

  • update dependency com.google.api:gax-bom to v2.6.1 (#600) (a0cff6a)

2.1.8 (2021-10-15)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.32.2 (#593) (644fc6f)
  • update dependency com.google.api:api-common to v2.0.4 (#585) (ad4e4b7)
  • update dependency com.google.api:api-common to v2.0.5 (#589) (c30cc40)
  • update dependency com.google.api:gax-bom to v2.6.0 (#594) (710cbe6)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.6.0 (#578) (113b686)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.1.3 (#574) (338444b)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.1.4 (#584) (57211ce)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.1.5 (#587) (55f9f4e)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.1.6 (#590) (f534c46)
  • update dependency com.google.auth:google-auth-library-bom to v1.2.0 (#581) (c32d2c5)
  • update dependency com.google.auth:google-auth-library-bom to v1.2.1 (#591) (046f95d)
  • update dependency com.google.guava:guava-bom to v31 (#577) (4a987fb)
  • update dependency com.google.http-client:google-http-client-bom to v1.40.1 (#588) (3d36d77)
  • update dependency com.google.protobuf:protobuf-bom to v3.18.1 (#583) (47da21c)

2.1.7 (2021-09-23)

Dependencies

  • update dependency io.grpc:grpc-bom to v1.41.0 (#569) (36703e9)

2.1.6 (2021-09-21)

Dependencies

  • update dependency com.google.api:gax-bom to v2.5.0 (#565) (3ce8e28)

2.1.5 (2021-09-21)

Dependencies

2.1.4 (2021-09-15)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.1.1 (#556) (095efa1)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.1.2 (#559) (3cda672)
  • update dependency com.google.protobuf:protobuf-bom to v3.18.0 (#558) (85766e6)

2.1.3 (2021-09-10)

Dependencies

  • update dependency com.google.api:gax-bom to v2.4.1 (#549) (0b4be35)

2.1.2 (2021-08-31)

Dependencies

  • update dependency com.google.api:api-common to v2.0.2 (#534) (1883c81)
  • update dependency com.google.api:gax-bom to v2.4.0 (#540) (06b0d6e)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.5.0 (#539) (9d5a0b0)
  • update dependency com.google.http-client:google-http-client-bom to v1.40.0 (#538) (150e07d)
  • update dependency io.grpc:grpc-bom to v1.40.1 (#535) (3cd48a9)

2.1.1 (2021-08-24)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.1.0 (#531) (1b27f8c)

2.1.0 (2021-08-23)

Features

  • support downloading an emulator from an access controlled URL (#513) (f42a707)

Dependencies

  • update dependency com.google.api:gax-bom to v2.3.0 (#523) (6fa1d96)
  • update dependency com.google.auth:google-auth-library-bom to v1.1.0 (#526) (0fc1532)
  • update dependency com.google.code.gson:gson to v2.8.8 (#529) (92b7f97)
  • update dependency com.google.errorprone:error_prone_annotations to v2.9.0 (#528) (5ecba07)
  • update dependency io.grpc:grpc-bom to v1.40.0 (#525) (a1e81f7)

2.0.5 (2021-08-11)

Dependencies

  • update dependency com.google.api:gax-bom to v2.1.0 (#519) (266e2f7)

2.0.4 (2021-08-11)

Dependencies

  • update dependency com.google.api:api-common to v2.0.1 (#516) (aa6abf3)

2.0.3 (2021-08-10)

Dependencies

  • update dependency com.google.errorprone:error_prone_annotations to v2.8.1 (#512) (6127b8f)

2.0.2 (2021-08-03)

Features

2.0.1 (2021-08-03)

Dependencies

  • update dependency com.google.api:gax-bom to v2 (#506) (a0c49a2)

2.0.0 (2021-07-29)

Features

Bug Fixes

  • Add shopt -s nullglob to dependencies script (1fa147c)
  • Update dependencies.sh to not break on mac (#484) (1fa147c)

Dependencies

  • update dependency com.google.api:api-common to v1.10.6 (#494) (1353d7b)
  • update dependency com.google.api:api-common to v2 (#497) (05edb6e)
  • update dependency com.google.api:gax-bom to v1.66.0 (#483) (0698c66)
  • update dependency com.google.api:gax-bom to v1.67.0 (#491) (65f4a1e)
  • update dependency com.google.auth:google-auth-library-bom to v0.27.0 (#489) (21b0afe)
  • update dependency com.google.auth:google-auth-library-bom to v1 (#496) (9cddefc)
  • update dependency com.google.errorprone:error_prone_annotations to v2.8.0 (#492) (acd03c0)
  • update dependency io.grpc:grpc-bom to v1.39.0 (#482) (02e69d4)
  • update guava 30.1.1-jre (#503) (cac0c63)

1.95.4 (2021-06-25)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.32.1 (#479) (5f9f732)

1.95.3 (2021-06-23)

Dependencies

  • update dependency com.google.api:api-common to v1.10.4 (#475) (5c8223d)
  • update dependency io.grpc:grpc-bom to v1.38.1 (#476) (b6a7923)

1.95.2 (2021-06-09)

Dependencies

  • update dependency com.google.api:gax-bom to v1.65.1 (#471) (3814364)

1.95.1 (2021-06-09)

Dependencies

  • update dependency com.google.protobuf:protobuf-bom to v3.17.3 (#468) (d456df2)

1.95.0 (2021-06-03)

Features

  • add gcf-owl-bot[bot] to ignoreAuthors (#453) (33d8edf)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.31.5 (#446) (fa83a61)
  • update dependency com.google.api:gax-bom to v1.64.0-sp.1 (#443) (19efb61)
  • update dependency com.google.api:gax-bom to v1.65.0 (#464) (bb15bf9)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.2.2 (#449) (42bf8ea)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.3.0 (#458) (eb930c2)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.3.1 (#463) (c2b2907)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.3.2 (#466) (fd68350)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.14 (#439) (c32bd33)
  • update dependency com.google.auth:google-auth-library-bom to v0.26.0 (#456) (97bb7a9)
  • update dependency com.google.code.gson:gson to v2.8.7 (#461) (4381e02)
  • update dependency com.google.errorprone:error_prone_annotations to v2.7.1 (#451) (8bf562f)
  • update dependency com.google.protobuf:protobuf-bom to v3.17.0 (#445) (aa9d87c)
  • update dependency com.google.protobuf:protobuf-bom to v3.17.1 (#460) (4edf784)
  • update dependency com.google.protobuf:protobuf-bom to v3.17.2 (#465) (f9b847a)
  • update dependency io.grpc:grpc-bom to v1.38.0 (#450) (bde03c1)

1.94.8 (2021-04-23)

Bug Fixes

Dependencies

  • update dependency com.google.api:api-common to v1.10.3 (#437) (e853d98)
  • update dependency com.google.auth:google-auth-library-bom to v0.25.4 (#428) (7cc490d)
  • update dependency com.google.auth:google-auth-library-bom to v0.25.5 (#435) (7f7f362)
  • update dependency org.threeten:threetenbp to v1.5.1 (#433) (af08225)

1.94.7 (2021-04-12)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.31.4 (#424) (6773b81)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.12 (#425) (df2ba7a)

1.94.6 (2021-04-09)

Dependencies

  • update dependency com.google.http-client:google-http-client-bom to v1.39.2 (#420) (541355d)

1.94.5 (2021-04-08)

Dependencies

  • update dependency com.google.api:gax-bom to v1.63.0 (#415) (31d41f3)
  • update dependency com.google.auth:google-auth-library-bom to v0.25.2 (#408) (bfb3cae)
  • update dependency com.google.errorprone:error_prone_annotations to v2.6.0 (#412) (e78e5d9)
  • update dependency com.google.http-client:google-http-client-bom to v1.39.1 (#407) (9ac757f)
  • update dependency com.google.protobuf:protobuf-bom to v3.15.6 (#405) (a20bce4)
  • update dependency com.google.protobuf:protobuf-bom to v3.15.7 (#413) (16d2bf5)
  • update dependency com.google.protobuf:protobuf-bom to v3.15.8 (#418) (101910c)
  • update dependency io.grpc:grpc-bom to v1.36.1 (#410) (e31620a)
  • update dependency io.grpc:grpc-bom to v1.37.0 (#416) (690fe8f)
  • update guava (#417) (acaa804)

1.94.4 (2021-03-11)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.11 (#402) (73d893c)
  • update dependency com.google.protobuf:protobuf-bom to v3.15.5 (#399) (a9c2e43)

1.94.3 (2021-03-02)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.31.3 (#394) (278cb03)
  • update dependency com.google.auth:google-auth-library-bom to v0.24.1 (#390) (9948791)

1.94.2 (2021-03-01)

Bug Fixes

Dependencies

  • switch from Jackson to GSON (#368) (220df17)
  • update dependency com.google.api-client:google-api-client-bom to v1.31.2 (#359) (107a32a)
  • update dependency com.google.api:gax-bom to v1.62.0 (2374ca7)
  • update dependency com.google.api.grpc:proto-google-common-protos to v2.1.0 (#387) (c55f950)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.10 (#392) (45b5abf)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.5 (#345) (0a5596d)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.7 (#357) (3c2b7b4)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.9 (#372) (82840da)
  • update dependency com.google.auth:google-auth-library-bom to v0.22.2 (#343) (3b418f7)
  • update dependency com.google.auth:google-auth-library-bom to v0.23.0 (#364) (7d52e06)
  • update dependency com.google.auth:google-auth-library-bom to v0.24.0 (#382) (44d8d02)
  • update dependency com.google.errorprone:error_prone_annotations to v2.5.1 (#354) (e7a688c)
  • update dependency com.google.guava:guava-bom to v30.1-android (#348) (0f2eadd)
  • update dependency com.google.http-client:google-http-client-bom to v1.38.1 (#358) (8fdc254)
  • update dependency com.google.http-client:google-http-client-bom to v1.39.0 (2374ca7)
  • update dependency com.google.protobuf:protobuf-bom to v3.15.0 (#378) (4314da9)
  • update dependency com.google.protobuf:protobuf-bom to v3.15.1 (#381) (09fac9d)
  • update dependency com.google.protobuf:protobuf-bom to v3.15.2 (#385) (8c2c179)
  • update dependency com.google.protobuf:protobuf-bom to v3.15.3 (#391) (6e03ce5)
  • update dependency io.grpc:grpc-bom to v1.34.1 (#342) (b80c3da)
  • update dependency opencensus to v0.28.0 (2374ca7)
  • update io.grpc:grpc-bom to v1.36.0 (#389) (2374ca7)

1.94.1 (2020-12-11)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.31.1 (#331) (e01ec17)
  • update dependency com.google.api:gax-bom to v1.60.1 (#340) (e3219b4)
  • update dependency com.google.protobuf:protobuf-bom to v3.14.0 (#335) (0fc6971)

1.94.0 (2020-11-10)

Features

  • test: add new MultipleAttemptRule, StdOutCaptureRule & StdErrCaptureRule JUnit 4 rules (#327) (60f4a66)

Dependencies

  • update dependency com.google.api.grpc:proto-google-common-protos to v2.0.1 (#323) (4b989e8)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.3 (#324) (a40c71a)
  • update dependency com.google.http-client:google-http-client-bom to v1.38.0 (#325) (48f1da7)
  • update dependency io.grpc:grpc-bom to v1.33.1 (#319) (8a788a6)

1.93.10 (2020-10-30)

Dependencies

  • update core dependencies (#294) (dcb6a67)
  • update core transport dependencies (#295) (341c032)
  • update dependency com.google.api:api-common to v1.10.1 (#302) (34260c0)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.2 (#312) (16e375a)
  • update dependency com.google.guava:guava-bom to v30 (#310) (17962f8)
  • update dependency io.grpc:grpc-bom to v1.33.0 (#309) (e9ac780)
  • update dependency org.threeten:threetenbp to v1.4.5 (#297) (a0b878f)
  • update dependency org.threeten:threetenbp to v1.5.0 (#314) (485b30f)

1.93.9 (2020-09-23)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1.0.1 (#282) (933172c)
  • update dependency com.google.protobuf:protobuf-bom to v3.13.0 (#273) (4476f33)
  • update dependency io.grpc:grpc-bom to v1.32.1 (#270) (df518d3)

1.93.8 (2020-08-12)

Bug Fixes

  • docs of com.google.cloud.Timestamp.parseTimestamp (#258) (964dd14)

Dependencies

  • update core dependencies (#263) (44023c3)
  • update dependency com.google.api-client:google-api-client-bom to v1.30.10 (#253) (0fd53fe)
  • update dependency com.google.api:api-common to v1.10.0 (#261) (1414e01)
  • update dependency com.google.api.grpc:proto-google-common-protos to v1.18.1 (#268) (b59a83c)
  • update dependency com.google.api.grpc:proto-google-iam-v1 to v1 (#269) (fe3987e)
  • update dependency com.google.protobuf:protobuf-bom to v3.12.4 (#262) (2ffca65)

1.93.7 (2020-07-08)

Dependencies

  • update core dependencies (#241) (60a4a05)
  • update dependency com.google.api:api-common to v1.9.3 (#250) (792cb60)
  • update dependency com.google.api:gax-bom to v1.57.1 (#251) (dd1a8a9)
  • update dependency com.google.auth:google-auth-library-bom to v0.21.1 (#252) (4844b26)
  • update dependency com.google.errorprone:error_prone_annotations to v2.4.0 (#226) (b2fd33c)
  • update dependency com.google.http-client:google-http-client-bom to v1.36.0 (#248) (34deaf9)

1.93.6 (2020-06-12)

Dependencies

  • update dependency com.google.api:api-common to v1.9.1 (#221) (4df33f0)
  • update dependency com.google.api:api-common to v1.9.2 (#229) (e8c1aa2)
  • update dependency com.google.api:gax-bom to v1.57.0 (#236) (3d7d2a6)
  • update dependency com.google.protobuf:protobuf-bom to v3.12.2 (#220) (815569d)
  • update dependency io.grpc:grpc-bom to v1.30.0 (#233) (b41c34f)

1.93.5 (2020-05-26)

Dependencies

  • rely on shared-config for auto-value configuration (#222) (22adbcf)
  • update dependency com.google.api.grpc:proto-google-common-protos to v1.18.0 (#215) (488a351)
  • update dependency com.google.guava:guava-bom to v29 (#205) (48d3f97)
  • update dependency com.google.http-client:google-http-client-bom to v1.35.0 (#211) (e56b3ef)
  • update dependency com.google.protobuf:protobuf-bom to v3.12.0 (#218) (b2c6f15)
  • update dependency io.grpc:grpc-bom to v1.29.0 (#209) (e63cb7c)
  • update dependency org.threeten:threetenbp to v1.4.4 (#210) (a837fa4)

1.93.4 (2020-04-06)

Dependencies

  • update core dependencies (#198) (129b3f8)
  • update dependency com.google.api:api-common to v1.9.0 (#195) (ac19258)
  • update dependency com.google.api:gax-bom to v1.56.0 (#201) (875c4ed)
  • update dependency org.threeten:threetenbp to v1.4.3 (#192) (ce6ec17)

1.93.3 (2020-03-16)

Bug Fixes

  • fix Timestamp.of(java.sql.Timestamp) pre-epoch on exact second (#179) (9bfb54c)
  • retry SSLException (#183) (775a848)

Dependencies

1.93.2 (2020-03-10)

Bug Fixes

  • verify correctness of map -> list equality (#174) (f45d913)

1.93.1 (2020-02-28)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.30.9 (#171) (1fdcd5e)

1.93.0 (2020-02-27)

Features

Bug Fixes

  • fix conversion for pre-epoch timestamps (#160) (1f8b6b4)

Dependencies

  • update dependency com.google.api:gax-bom to v1.54.0 (#168) (5b52f9e)
  • update dependency io.grpc:grpc-bom to v1.27.2 (#166) (28c9859)

1.92.5 (2020-02-10)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.30.8 (#146) (1d9c7db)
  • update dependency com.google.protobuf:protobuf-bom to v3.11.3 (#148) (092c69b)

1.92.4 (2020-01-31)

Dependencies

1.92.3 (2020-01-28)

Dependencies

  • update dependency com.google.api:gax-bom to v1.53.0 (#126) (bdb1bce)
  • update dependency com.google.auth:google-auth-library-bom to v0.20.0 (#135) (f40c636)
  • update dependency com.google.http-client:google-http-client-bom to v1.34.1 (#137) (9216702)
  • update dependency org.threeten:threetenbp to v1.4.1 (82cac64)

1.92.2 (2020-01-09)

Bug Fixes

1.92.1 (2020-01-02)

Dependencies

  • update dependency com.google.errorprone:error_prone_annotations to v2.3.4 (#105) (52f47c5)
  • update dependency com.google.guava:guava-bom to v28.2-android (#113) (8b11b1a)
  • update dependency com.google.http-client:google-http-client-bom to v1.34.0 (#98) (d8e946d)
  • update dependency com.google.protobuf:protobuf-bom to v3.11.1 (#106) (6d36434)
  • update dependency io.grpc:grpc-bom to v1.26.0 (#107) (fca41a7)

1.92.0 (2019-12-13)

Features

  • increase DEFAULT_CHUNK_SIZE to reduce transfer overhead (#87) (09b327d)
  • support setting ServiceOption for quota project (#92) (6aa4476)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.30.5 (#68) (e1a4047)
  • update dependency com.google.api:gax-bom to v1.50.1 (#73) (f493b5b)
  • update dependency com.google.api:gax-bom to v1.51.0 (#85) (71d0de7)
  • update dependency com.google.auth:google-auth-library-bom to v0.19.0 (#93) (b465630)
  • update dependency com.google.http-client:google-http-client-bom to v1.33.0 (#71) (8f1e690)
  • update dependency io.grpc:grpc-bom to v1.25.0 (#72) (3a09fc7)
  • update to threetenbp 1.4.0 (#89) (5128bd4)

1.91.3 (2019-10-23)

Bug Fixes

  • try to keep autovalue out of the runtime time classpath (#48) (0988c27)

Dependencies

  • update dependency com.google.api:gax-bom to v1.49.1 (#65) (131a0fd)
  • update dependency com.google.api.grpc:proto-google-common-protos to v1.17.0 (#50) (3ba5512)
  • update dependency com.google.auth:google-auth-library-bom to v0.18.0 (#56) (ab25f15)
  • update dependency io.grpc:grpc-bom to v1.24.1 (07fefbb)

1.91.2 (2019-09-30)

Dependencies

  • update dependency com.google.api.grpc:proto-google-iam-v1 to v0.13.0 (#40) (4f500cc)
  • update dependency io.grpc:grpc-bom to v1.24.0 (#39) (7f6f780)
  • update errorprone to 2.3.3 (#43) (232694c)

1.91.1 (2019-09-25)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.30.4 (#34) (886eda3)
  • update dependency com.google.auth:google-auth-library-bom to v0.17.2 (#35) (ae44c72)
  • update dependency com.google.http-client:google-http-client-bom to v1.32.1 (#31) (4bdf09b)
  • update dependency com.google.protobuf:protobuf-bom to v3.10.0 (#27) (23e4c26)
  • update guava to 28.1-android (#32) (0279479)

1.91.0 (2019-09-18)

Dependencies

  • update dependency com.google.api-client:google-api-client-bom to v1.30.3 (#21) (fcd67f8)
  • update opencensus packages to v0.24.0 (#22) (4b21afa)

Documentation

  • fix Kokoro badge link (19d79d6)
  • fix README versions and CI Status table (6e3ccf3)
  • update README with a better project description (#17) (018d4d5)

Features

  • add google-cloud-core-bom artifact (#13) (3cb19a0)