Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

deps!: update dependency com.google.api:api-common to v2 #497

Conversation

renovate-bot
Copy link
Contributor

@renovate-bot renovate-bot commented Jul 29, 2021

WhiteSource Renovate

This PR contains the following updates:

Package Change Age Adoption Passing Confidence
com.google.api:api-common 1.10.6 -> 2.0.0 age adoption passing confidence

Release Notes

googleapis/api-common-java

v2.0.0

Compare Source

BREAKING CHANGES
  • update api-common-java min java version to java8 (#​251)
Features
  • update api-common-java min java version to java8 (#​251) (7fe322c)
Dependencies
  • update guava version to 30.1.1-jre (7fe322c)
1.10.5 (2021-07-27)
Build System
Dependencies
  • update dependency com.google.auto.value:auto-value to v1.8.2 (#​242) (5de2f3e)
  • update dependency com.google.auto.value:auto-value-annotations to v1.8.2 (#​243) (53d6d38)
  • update dependency com.google.errorprone:error_prone_annotations to v2.8.0 (#​245) (8889689)
1.10.5 (2021-07-20)
Bug Fixes
  • Fix PathTemplate custom verb logic matching and instantiating (#​244) (d4913d3)
Dependencies
  • update dependency io.codearte.gradle.nexus:gradle-nexus-staging-plugin to v0.30.0 (#​239) (2ca4359)
1.10.4 (2021-05-19)
Dependencies
  • update dependency com.google.errorprone:error_prone_annotations to v2.7.1 (#​231) (51b00e0)
1.10.3 (2021-04-22)
Dependencies
  • update dependency com.google.auto.value:auto-value to v1.8.1 (#​219) (307c640)
  • update dependency com.google.auto.value:auto-value-annotations to v1.8.1 (#​215) (15cebbc)
1.10.2 (2021-04-19)
Dependencies
1.10.1 (2020-10-16)
Dependencies
  • update dependency com.google.auto.value:auto-value to v1.7.4 (#​170) (e6f8fef)
  • update dependency com.google.auto.value:auto-value-annotations to v1.7.4 (#​171) (00a12b9)
  • update dependency com.google.errorprone:error_prone_annotations to v2.4.0 (#​172) (89b2a48)

Configuration

📅 Schedule: At any time (no schedule defined).

🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.

Rebasing: Renovate will not automatically rebase this PR, because other commits have been found.

🔕 Ignore: Close this PR and you won't be reminded about this update again.


  • If you want to rebase/retry this PR, check this box.

This PR has been generated by WhiteSource Renovate. View repository job log here.

@renovate-bot renovate-bot requested a review from as a code owner Jul 29, 2021
@google-cla google-cla bot added the cla: yes label Jul 29, 2021
@trusted-contributions-gcf trusted-contributions-gcf bot added kokoro:force-run owlbot:run labels Jul 29, 2021
@gcf-owl-bot gcf-owl-bot bot removed the owlbot:run label Jul 29, 2021
@yoshi-kokoro yoshi-kokoro removed the kokoro:force-run label Jul 29, 2021
@renovate-bot renovate-bot force-pushed the renovate/major-google.api-common.version branch from e60a843 to 706001d Compare Jul 29, 2021
@trusted-contributions-gcf trusted-contributions-gcf bot added kokoro:force-run owlbot:run labels Jul 29, 2021
@gcf-owl-bot gcf-owl-bot bot removed the owlbot:run label Jul 29, 2021
@yoshi-kokoro yoshi-kokoro removed the kokoro:force-run label Jul 29, 2021
@trusted-contributions-gcf trusted-contributions-gcf bot added kokoro:force-run owlbot:run labels Jul 29, 2021
@gcf-owl-bot gcf-owl-bot bot removed the owlbot:run label Jul 29, 2021
@yoshi-kokoro yoshi-kokoro removed the kokoro:force-run label Jul 29, 2021
@Neenu1995 Neenu1995 changed the title deps: update dependency com.google.api:api-common to v2 deps!: update dependency com.google.api:api-common to v2 Jul 29, 2021
@Neenu1995 Neenu1995 added the automerge label Jul 29, 2021
@Neenu1995 Neenu1995 merged commit 05edb6e into googleapis:master Jul 29, 2021
17 of 18 checks passed
@gcf-merge-on-green gcf-merge-on-green bot removed the automerge label Jul 29, 2021
@renovate-bot renovate-bot deleted the renovate/major-google.api-common.version branch Jul 29, 2021
gcf-merge-on-green bot pushed a commit that referenced this issue Jul 29, 2021
🤖 I have created a release \*beep\* \*boop\*
---
## [2.0.0](https://www.github.com/googleapis/java-core/compare/v1.95.4...v2.0.0) (2021-07-29)


### Features

* promote to 2.0.0 ([#504](https://www.github.com/googleapis/java-core/issues/504)) ([48076ba](https://www.github.com/googleapis/java-core/commit/48076bafa2a89dc6b3ad88a698166da8ebb144f4))


### Bug Fixes

* Add shopt -s nullglob to dependencies script ([1fa147c](https://www.github.com/googleapis/java-core/commit/1fa147c9cded08f9eea4a717c622c0b33ad239d0))
* Update dependencies.sh to not break on mac ([#484](https://www.github.com/googleapis/java-core/issues/484)) ([1fa147c](https://www.github.com/googleapis/java-core/commit/1fa147c9cded08f9eea4a717c622c0b33ad239d0))


### Dependencies

* update dependency com.google.api:api-common to v1.10.6 ([#494](https://www.github.com/googleapis/java-core/issues/494)) ([1353d7b](https://www.github.com/googleapis/java-core/commit/1353d7b42dc98110733d279404f9295067f632cf))
* update dependency com.google.api:api-common to v2 ([#497](https://www.github.com/googleapis/java-core/issues/497)) ([05edb6e](https://www.github.com/googleapis/java-core/commit/05edb6ec2156978b49e72f16de35a935acd43ca8))
* update dependency com.google.api:gax-bom to v1.66.0 ([#483](https://www.github.com/googleapis/java-core/issues/483)) ([0698c66](https://www.github.com/googleapis/java-core/commit/0698c6679877e0666c684ea5c5daaf8ebae7c15c))
* update dependency com.google.api:gax-bom to v1.67.0 ([#491](https://www.github.com/googleapis/java-core/issues/491)) ([65f4a1e](https://www.github.com/googleapis/java-core/commit/65f4a1e4ace1ec70cd2a151233c626d80874beb4))
* update dependency com.google.auth:google-auth-library-bom to v0.27.0 ([#489](https://www.github.com/googleapis/java-core/issues/489)) ([21b0afe](https://www.github.com/googleapis/java-core/commit/21b0afea717805dfd5c93929d2a72de86f048781))
* update dependency com.google.auth:google-auth-library-bom to v1 ([#496](https://www.github.com/googleapis/java-core/issues/496)) ([9cddefc](https://www.github.com/googleapis/java-core/commit/9cddefc0fdb0eb400121db0faf18bf1bdfdfc7f5))
* update dependency com.google.errorprone:error_prone_annotations to v2.8.0 ([#492](https://www.github.com/googleapis/java-core/issues/492)) ([acd03c0](https://www.github.com/googleapis/java-core/commit/acd03c00896a1e8f6ab948823e5a5ebd5b741115))
* update dependency io.grpc:grpc-bom to v1.39.0 ([#482](https://www.github.com/googleapis/java-core/issues/482)) ([02e69d4](https://www.github.com/googleapis/java-core/commit/02e69d46d3b8a71b6286915e08e987a5fc9ce8a6))
* update guava 30.1.1-jre ([#503](https://www.github.com/googleapis/java-core/issues/503)) ([cac0c63](https://www.github.com/googleapis/java-core/commit/cac0c6367d42afb8af2dec56b9eec4de2e95978e))
---


This PR was generated with [Release Please](https://github.com/googleapis/release-please). See [documentation](https://github.com/googleapis/release-please#release-please).
aristide-n pushed a commit to aristide-n/java-core that referenced this issue Aug 8, 2021
Co-authored-by: Neenu Shaji <Neenu1995@users.noreply.github.com>
aristide-n pushed a commit to aristide-n/java-core that referenced this issue Aug 8, 2021
🤖 I have created a release \*beep\* \*boop\*
---
## [2.0.0](https://www.github.com/googleapis/java-core/compare/v1.95.4...v2.0.0) (2021-07-29)


### Features

* promote to 2.0.0 ([googleapis#504](https://www.github.com/googleapis/java-core/issues/504)) ([48076ba](https://www.github.com/googleapis/java-core/commit/48076bafa2a89dc6b3ad88a698166da8ebb144f4))


### Bug Fixes

* Add shopt -s nullglob to dependencies script ([1fa147c](https://www.github.com/googleapis/java-core/commit/1fa147c9cded08f9eea4a717c622c0b33ad239d0))
* Update dependencies.sh to not break on mac ([googleapis#484](https://www.github.com/googleapis/java-core/issues/484)) ([1fa147c](https://www.github.com/googleapis/java-core/commit/1fa147c9cded08f9eea4a717c622c0b33ad239d0))


### Dependencies

* update dependency com.google.api:api-common to v1.10.6 ([googleapis#494](https://www.github.com/googleapis/java-core/issues/494)) ([1353d7b](https://www.github.com/googleapis/java-core/commit/1353d7b42dc98110733d279404f9295067f632cf))
* update dependency com.google.api:api-common to v2 ([googleapis#497](https://www.github.com/googleapis/java-core/issues/497)) ([05edb6e](https://www.github.com/googleapis/java-core/commit/05edb6ec2156978b49e72f16de35a935acd43ca8))
* update dependency com.google.api:gax-bom to v1.66.0 ([googleapis#483](https://www.github.com/googleapis/java-core/issues/483)) ([0698c66](https://www.github.com/googleapis/java-core/commit/0698c6679877e0666c684ea5c5daaf8ebae7c15c))
* update dependency com.google.api:gax-bom to v1.67.0 ([googleapis#491](https://www.github.com/googleapis/java-core/issues/491)) ([65f4a1e](https://www.github.com/googleapis/java-core/commit/65f4a1e4ace1ec70cd2a151233c626d80874beb4))
* update dependency com.google.auth:google-auth-library-bom to v0.27.0 ([googleapis#489](https://www.github.com/googleapis/java-core/issues/489)) ([21b0afe](https://www.github.com/googleapis/java-core/commit/21b0afea717805dfd5c93929d2a72de86f048781))
* update dependency com.google.auth:google-auth-library-bom to v1 ([googleapis#496](https://www.github.com/googleapis/java-core/issues/496)) ([9cddefc](https://www.github.com/googleapis/java-core/commit/9cddefc0fdb0eb400121db0faf18bf1bdfdfc7f5))
* update dependency com.google.errorprone:error_prone_annotations to v2.8.0 ([googleapis#492](https://www.github.com/googleapis/java-core/issues/492)) ([acd03c0](https://www.github.com/googleapis/java-core/commit/acd03c00896a1e8f6ab948823e5a5ebd5b741115))
* update dependency io.grpc:grpc-bom to v1.39.0 ([googleapis#482](https://www.github.com/googleapis/java-core/issues/482)) ([02e69d4](https://www.github.com/googleapis/java-core/commit/02e69d46d3b8a71b6286915e08e987a5fc9ce8a6))
* update guava 30.1.1-jre ([googleapis#503](https://www.github.com/googleapis/java-core/issues/503)) ([cac0c63](https://www.github.com/googleapis/java-core/commit/cac0c6367d42afb8af2dec56b9eec4de2e95978e))
---


This PR was generated with [Release Please](https://github.com/googleapis/release-please). See [documentation](https://github.com/googleapis/release-please#release-please).
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
cla: yes
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants