Skip to content
Permalink
Browse files
fix: dependencies.sh to work with Java 17 (#516)
  • Loading branch information
suztomo committed Nov 10, 2021
1 parent b9a8209 commit 8422c1d7e9ef479f348e63c530789050b5235426
Showing with 4 additions and 7 deletions.
  1. +4 −7 .kokoro/dependencies.sh
@@ -37,16 +37,13 @@ function determineMavenOpts() {
| sed -E 's/^.*"(.*?)".*$/\1/g' \
| sed -E 's/^(1\.[0-9]\.0).*$/\1/g'
)

case $javaVersion in
"17")
if [[ $javaVersion == 17* ]]
then
# MaxPermSize is no longer supported as of jdk 17
echo -n "-Xmx1024m"
;;
*)
else
echo -n "-Xmx1024m -XX:MaxPermSize=128m"
;;
esac
fi
}

export MAVEN_OPTS=$(determineMavenOpts)

0 comments on commit 8422c1d

Please sign in to comment.