Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fix: include an explicit version for javax-annotations-api #261

Merged
merged 1 commit into from Jun 11, 2020

Conversation

olavloite
Copy link
Contributor

@olavloite olavloite commented Jun 11, 2020

The Maven flatten plugin transforms the pom of the project from a set of imports and transitive dependencies into a pom that contains all dependencies and versions explicitly. This process did however miss the javax-annotations-api dependency that is only included for JDK9 and higher.

Fixes GoogleCloudPlatform/java-docs-samples#3139

The Maven flatten plugin transforms the pom of the project from a set of imports
and transitive dependencies into a pom that contains all dependencies and versions
explicitly. This process did however miss the javax-annotations-api dependency that
is only included for JDK9 and higher.

Fixes GoogleCloudPlatform/java-docs-samples#3139
@olavloite olavloite requested review from chingor13 and skuruppu Jun 11, 2020
@googlebot googlebot added the cla: yes label Jun 11, 2020
@olavloite olavloite merged commit e256d22 into master Jun 11, 2020
20 checks passed
@olavloite olavloite deleted the include-version-for-javax-annotation-api branch Jun 11, 2020
@stephaniewang526
Copy link
Member

@stephaniewang526 stephaniewang526 commented Jun 11, 2020

mojohaus/flatten-maven-plugin#155 should fix this problem in the plugin -- we're waiting on a release by flatten maven plugin.

@lesv

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
cla: yes
Projects
None yet
Development

Successfully merging this pull request may close these issues.

4 participants