Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

deps: update dependency com.google.cloud:google-cloud-shared-dependencies to v0.8.6 #374

Conversation

renovate-bot
Copy link
Contributor

@renovate-bot renovate-bot commented Aug 4, 2020

This PR contains the following updates:

Package Update Change
com.google.cloud:google-cloud-shared-dependencies patch 0.8.3 -> 0.8.6

Release Notes

googleapis/java-shared-dependencies

v0.8.6

Compare Source

v0.8.5

Compare Source

v0.8.4

Compare Source


Renovate configuration

馃搮 Schedule: At any time (no schedule defined).

馃殾 Automerge: Disabled by config. Please merge this manually once you are satisfied.

鈾伙笍 Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

馃敃 Ignore: Close this PR and you won't be reminded about this update again.


  • If you want to rebase/retry this PR, check this box

This PR has been generated by WhiteSource Renovate. View repository job log here.

@google-cla google-cla bot added the cla: yes label Aug 4, 2020
@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Aug 4, 2020
@yoshi-kokoro yoshi-kokoro removed the kokoro:run label Aug 4, 2020
@skuruppu
Copy link
Contributor

@skuruppu skuruppu commented Aug 6, 2020

@olavloite would you be able to help us figure out why the tests are failing with this update? Essentially, there are a bunch of failures to do with the admin clients both in unit and integration tests.

@olavloite
Copy link
Contributor

@olavloite olavloite commented Aug 6, 2020

@olavloite would you be able to help us figure out why the tests are failing with this update? Essentially, there are a bunch of failures to do with the admin clients both in unit and integration tests.

The problem is caused by the fact that the generated gapic clients are sending an incomplete header to the (mock) servers. The header that is sent is the following: x-goog-api-client=gl-java/1.7.0_191 gapic/ gax/ grpc/1.31.0. This header value no longer include a version number for gax, but this is required by the generated tests. These tests try to verify that the header value match with the following pattern: gl-java/.+ gapic/.* gax/.+ grpc/.+.

My guess is that it is caused by the change introduced by this commit: googleapis/gax-java@ecbab4a

Gax is now trying to determine its version based on a text file that is read here: https://github.com/googleapis/gax-java/blob/ecbab4a5c2100552ec428208b29adfad8e1da9a3/gax/src/main/java/com/google/api/gax/core/GaxProperties.java#L69. That file is not found, which means that null is returned, and no version is included in the header that is sent to the server.

@renovate-bot renovate-bot force-pushed the renovate/com.google.cloud-google-cloud-shared-dependencies-0.x branch from e8c0996 to cbc68c7 Compare Aug 7, 2020
@renovate-bot renovate-bot changed the title deps: update dependency com.google.cloud:google-cloud-shared-dependencies to v0.8.4 deps: update dependency com.google.cloud:google-cloud-shared-dependencies to v0.8.5 Aug 7, 2020
@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Aug 7, 2020
@yoshi-kokoro yoshi-kokoro removed the kokoro:run label Aug 7, 2020
@renovate-bot renovate-bot force-pushed the renovate/com.google.cloud-google-cloud-shared-dependencies-0.x branch from cbc68c7 to 0eee7ea Compare Aug 7, 2020
@renovate-bot renovate-bot changed the title deps: update dependency com.google.cloud:google-cloud-shared-dependencies to v0.8.5 deps: update dependency com.google.cloud:google-cloud-shared-dependencies to v0.8.6 Aug 7, 2020
@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Aug 7, 2020
@yoshi-kokoro yoshi-kokoro removed the kokoro:run label Aug 7, 2020
@chingor13 chingor13 added the automerge label Aug 7, 2020
@gcf-merge-on-green gcf-merge-on-green bot merged commit 6f47b8a into googleapis:master Aug 7, 2020
15 checks passed
@renovate-bot renovate-bot deleted the renovate/com.google.cloud-google-cloud-shared-dependencies-0.x branch Aug 7, 2020
gcf-merge-on-green bot pushed a commit that referenced this issue Aug 20, 2020
馃 I have created a release \*beep\* \*boop\* 
---
## [1.60.0](https://www.github.com/googleapis/java-spanner/compare/v1.59.0...v1.60.0) (2020-08-18)


### Features

* adds clirr check on pre-commit hook ([#388](https://www.github.com/googleapis/java-spanner/issues/388)) ([bd5c93f](https://www.github.com/googleapis/java-spanner/commit/bd5c93f045e06372b2235f3d350bade93bff2c24))
* include SQL statement in error message ([#355](https://www.github.com/googleapis/java-spanner/issues/355)) ([cc5ac48](https://www.github.com/googleapis/java-spanner/commit/cc5ac48232b6e4550b98d213c5877d6ec37b293f))


### Bug Fixes

* enables emulator tests ([#380](https://www.github.com/googleapis/java-spanner/issues/380)) ([f61c6d0](https://www.github.com/googleapis/java-spanner/commit/f61c6d0d332f15826499996a292acc7cbab267a7))
* remove custom timeout and retry settings ([#365](https://www.github.com/googleapis/java-spanner/issues/365)) ([f6afd21](https://www.github.com/googleapis/java-spanner/commit/f6afd213430d3f06d9a72c64a5c37172840fed0e))
* remove unused kokoro files ([#367](https://www.github.com/googleapis/java-spanner/issues/367)) ([6125c7d](https://www.github.com/googleapis/java-spanner/commit/6125c7d221c77f4c42497b72107627ee09312813))
* retry pdml transaction on EOS internal error ([#360](https://www.github.com/googleapis/java-spanner/issues/360)) ([a53d736](https://www.github.com/googleapis/java-spanner/commit/a53d7369bb2a8640ab42e409632b352decbdbf5e))
* sets the project for the integration tests ([#386](https://www.github.com/googleapis/java-spanner/issues/386)) ([c8fa458](https://www.github.com/googleapis/java-spanner/commit/c8fa458f5369a09c780ee38ecc09bd2562e8f987))


### Dependencies

* stop auto updates of commons-lang3 ([#362](https://www.github.com/googleapis/java-spanner/issues/362)) ([8f07ed6](https://www.github.com/googleapis/java-spanner/commit/8f07ed6b44f9c70f56b9ee2e4505c40385337ca7))
* update dependency com.google.cloud:google-cloud-shared-dependencies to v0.8.6 ([#374](https://www.github.com/googleapis/java-spanner/issues/374)) ([6f47b8a](https://www.github.com/googleapis/java-spanner/commit/6f47b8a759643f772230df0c2e153338d44f70ce))
* update dependency org.openjdk.jmh:jmh-core to v1.24 ([#375](https://www.github.com/googleapis/java-spanner/issues/375)) ([94f568c](https://www.github.com/googleapis/java-spanner/commit/94f568cf731ba22cac7f0d898d7776a3cc2c178f))
* update dependency org.openjdk.jmh:jmh-core to v1.25 ([#382](https://www.github.com/googleapis/java-spanner/issues/382)) ([ec7888e](https://www.github.com/googleapis/java-spanner/commit/ec7888e1d62cf800bf6ad166d242e89443ddc7aa))
* update dependency org.openjdk.jmh:jmh-generator-annprocess to v1.25 ([#376](https://www.github.com/googleapis/java-spanner/issues/376)) ([8ffdc48](https://www.github.com/googleapis/java-spanner/commit/8ffdc481e15901f78eac592bd8d4bef33ac3378a))
---


This PR was generated with [Release Please](https://github.com/googleapis/release-please).
thiagotnunes pushed a commit to thiagotnunes/java-spanner that referenced this issue Jun 5, 2021
馃 I have created a release \*beep\* \*boop\* 
---
## [1.60.0](https://www.github.com/googleapis/java-spanner/compare/v1.59.0...v1.60.0) (2020-08-18)


### Features

* adds clirr check on pre-commit hook ([googleapis#388](https://www.github.com/googleapis/java-spanner/issues/388)) ([bd5c93f](https://www.github.com/googleapis/java-spanner/commit/bd5c93f045e06372b2235f3d350bade93bff2c24))
* include SQL statement in error message ([googleapis#355](https://www.github.com/googleapis/java-spanner/issues/355)) ([cc5ac48](https://www.github.com/googleapis/java-spanner/commit/cc5ac48232b6e4550b98d213c5877d6ec37b293f))


### Bug Fixes

* enables emulator tests ([googleapis#380](https://www.github.com/googleapis/java-spanner/issues/380)) ([f61c6d0](https://www.github.com/googleapis/java-spanner/commit/f61c6d0d332f15826499996a292acc7cbab267a7))
* remove custom timeout and retry settings ([googleapis#365](https://www.github.com/googleapis/java-spanner/issues/365)) ([f6afd21](https://www.github.com/googleapis/java-spanner/commit/f6afd213430d3f06d9a72c64a5c37172840fed0e))
* remove unused kokoro files ([googleapis#367](https://www.github.com/googleapis/java-spanner/issues/367)) ([6125c7d](https://www.github.com/googleapis/java-spanner/commit/6125c7d221c77f4c42497b72107627ee09312813))
* retry pdml transaction on EOS internal error ([googleapis#360](https://www.github.com/googleapis/java-spanner/issues/360)) ([a53d736](https://www.github.com/googleapis/java-spanner/commit/a53d7369bb2a8640ab42e409632b352decbdbf5e))
* sets the project for the integration tests ([googleapis#386](https://www.github.com/googleapis/java-spanner/issues/386)) ([c8fa458](https://www.github.com/googleapis/java-spanner/commit/c8fa458f5369a09c780ee38ecc09bd2562e8f987))


### Dependencies

* stop auto updates of commons-lang3 ([googleapis#362](https://www.github.com/googleapis/java-spanner/issues/362)) ([8f07ed6](https://www.github.com/googleapis/java-spanner/commit/8f07ed6b44f9c70f56b9ee2e4505c40385337ca7))
* update dependency com.google.cloud:google-cloud-shared-dependencies to v0.8.6 ([googleapis#374](https://www.github.com/googleapis/java-spanner/issues/374)) ([6f47b8a](https://www.github.com/googleapis/java-spanner/commit/6f47b8a759643f772230df0c2e153338d44f70ce))
* update dependency org.openjdk.jmh:jmh-core to v1.24 ([googleapis#375](https://www.github.com/googleapis/java-spanner/issues/375)) ([94f568c](https://www.github.com/googleapis/java-spanner/commit/94f568cf731ba22cac7f0d898d7776a3cc2c178f))
* update dependency org.openjdk.jmh:jmh-core to v1.25 ([googleapis#382](https://www.github.com/googleapis/java-spanner/issues/382)) ([ec7888e](https://www.github.com/googleapis/java-spanner/commit/ec7888e1d62cf800bf6ad166d242e89443ddc7aa))
* update dependency org.openjdk.jmh:jmh-generator-annprocess to v1.25 ([googleapis#376](https://www.github.com/googleapis/java-spanner/issues/376)) ([8ffdc48](https://www.github.com/googleapis/java-spanner/commit/8ffdc481e15901f78eac592bd8d4bef33ac3378a))
---


This PR was generated with [Release Please](https://github.com/googleapis/release-please).
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
automerge cla: yes
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

5 participants