Skip to content
Permalink
Browse files
feat: promote to GA (#185)
Release-As: 1.0.0
  • Loading branch information
chingor13 committed Jun 18, 2020
1 parent fcffa70 commit 710f6f593f61b434daf9f03d7579758e378eda9c
Showing with 9 additions and 15 deletions.
  1. +1 −1 .repo-metadata.json
  2. +2 −8 README.md
  3. +6 −6 synth.metadata
@@ -5,7 +5,7 @@
"client_documentation": "https://googleapis.dev/java/google-cloud-webrisk/latest/",
"api_description": "is a Google Cloud service that lets client applications check URLs against Google's constantly updated lists of unsafe web resources. Unsafe web resources include social engineering sites\u2014such as phishing and deceptive sites\u2014and sites that host malware or unwanted software. With the Web Risk API, you can quickly identify known bad sites, warn users before they click infected links, and prevent users from posting links to known infected pages from your site. The Web Risk API includes data on more than a million unsafe URLs and stays up to date by examining billions of URLs each day.",
"issue_tracker": "",
"release_level": "beta",
"release_level": "ga",
"language": "java",
"transport": "grpc",
"repo": "googleapis/java-webrisk",
@@ -8,9 +8,6 @@ Java idiomatic client for [Web Risk][product-docs].
- [Product Documentation][product-docs]
- [Client Library Documentation][javadocs]

> Note: This client is a work-in-progress, and may occasionally
> make backwards-incompatible changes.
## Quickstart

If you are using Maven with [BOM][libraries-bom], add this to your pom.xml file
@@ -20,7 +17,7 @@ If you are using Maven with [BOM][libraries-bom], add this to your pom.xml file
<dependency>
<groupId>com.google.cloud</groupId>
<artifactId>libraries-bom</artifactId>
<version>6.0.0</version>
<version>7.0.0</version>
<type>pom</type>
<scope>import</scope>
</dependency>
@@ -108,9 +105,6 @@ Java 7 or above is required for using this client.
This library follows [Semantic Versioning](http://semver.org/).


It is currently in major version zero (``0.y.z``), which means that anything may change at any time
and the public API should not be considered stable.

## Contributing


@@ -148,7 +142,7 @@ Java 11 | [![Kokoro CI][kokoro-badge-image-5]][kokoro-badge-link-5]
[kokoro-badge-link-4]: http://storage.googleapis.com/cloud-devrel-public/java/badges/java-webrisk/java8-win.html
[kokoro-badge-image-5]: http://storage.googleapis.com/cloud-devrel-public/java/badges/java-webrisk/java11.svg
[kokoro-badge-link-5]: http://storage.googleapis.com/cloud-devrel-public/java/badges/java-webrisk/java11.html
[stability-image]: https://img.shields.io/badge/stability-beta-yellow
[stability-image]: https://img.shields.io/badge/stability-ga-green
[maven-version-image]: https://img.shields.io/maven-central/v/com.google.cloud/google-cloud-webrisk.svg
[maven-version-link]: https://search.maven.org/search?q=g:com.google.cloud%20AND%20a:google-cloud-webrisk&core=gav
[authentication]: https://github.com/googleapis/google-cloud-java#authentication
@@ -4,30 +4,30 @@
"git": {
"name": ".",
"remote": "https://github.com/googleapis/java-webrisk.git",
"sha": "688a72a30d746e49e369d567391cc7d4e51218d7"
"sha": "fcffa703dadcb414bf5ede9786bfc8fccbf1c71f"
}
},
{
"git": {
"name": "googleapis",
"remote": "https://github.com/googleapis/googleapis.git",
"sha": "c4e37010d74071851ff24121f522e802231ac86e",
"internalRef": "313460921"
"sha": "13883b8fa7fc17ec20b563a31bc9d2aa1d491d4d",
"internalRef": "316978043"
}
},
{
"git": {
"name": "googleapis",
"remote": "https://github.com/googleapis/googleapis.git",
"sha": "c4e37010d74071851ff24121f522e802231ac86e",
"internalRef": "313460921"
"sha": "13883b8fa7fc17ec20b563a31bc9d2aa1d491d4d",
"internalRef": "316978043"
}
},
{
"git": {
"name": "synthtool",
"remote": "https://github.com/googleapis/synthtool.git",
"sha": "c4f3059c27591eb24d6942a0e357ec94c80459f2"
"sha": "b10590a4a1568548dd13cfcea9aa11d40898144b"
}
}
],

0 comments on commit 710f6f5

Please sign in to comment.