Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

deps: update dependency com.google.guava:guava-bom to v28.2-android #32

Merged
merged 1 commit into from Jan 30, 2020

Conversation

renovate-bot
Copy link
Contributor

@renovate-bot renovate-bot commented Dec 27, 2019

This PR contains the following updates:

Package Update Change
com.google.guava:guava-bom minor 28.1-android -> 28.2-android

Renovate configuration

馃搮 Schedule: At any time (no schedule defined).

馃殾 Automerge: Disabled by config. Please merge this manually once you are satisfied.

鈾伙笍 Rebasing: Whenever PR becomes conflicted, or if you tick the rebase/retry checkbox below.

馃敃 Ignore: Close this PR and you won't be reminded about this update again.


  • If you want to rebase/retry this PR, check this box

This PR has been generated by WhiteSource Renovate. View repository job log here.

@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Dec 27, 2019
@googlebot googlebot added the cla: yes label Dec 27, 2019
@kokoro-team kokoro-team removed the kokoro:run label Dec 27, 2019
@suztomo
Copy link
Member

@suztomo suztomo commented Dec 27, 2019

Memo for later reference:

Kokoro - Test: Dependencies 鈥 Build failed:

[INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce (enforce) @ grpc-google-cloud-websecurityscanner-v1alpha ---
[WARNING] Rule 2: org.apache.maven.plugins.enforcer.RequireUpperBoundDeps failed with message:
Failed while enforcing RequireUpperBoundDeps. The error(s) are [
Require upper bound dependencies error for com.google.errorprone:error_prone_annotations:2.3.3 paths to dependency are:
+-com.google.api.grpc:grpc-google-cloud-websecurityscanner-v1alpha:0.81.1-SNAPSHOT
  +-io.grpc:grpc-api:1.26.0
    +-com.google.errorprone:error_prone_annotations:2.3.3
and
+-com.google.api.grpc:grpc-google-cloud-websecurityscanner-v1alpha:0.81.1-SNAPSHOT
  +-com.google.guava:guava:28.2-android
    +-com.google.errorprone:error_prone_annotations:2.3.4
]

@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Jan 3, 2020
@codecov
Copy link

@codecov codecov bot commented Jan 3, 2020

Codecov Report

Merging #32 into master will decrease coverage by 0.71%.
The diff coverage is n/a.

Impacted file tree graph

@@             Coverage Diff              @@
##             master      #32      +/-   ##
============================================
- Coverage      76.3%   75.59%   -0.72%     
  Complexity      208      208              
============================================
  Files            12       12              
  Lines          1680     1680              
  Branches         22       10      -12     
============================================
- Hits           1282     1270      -12     
  Misses          352      352              
- Partials         46       58      +12
Impacted Files Coverage 螖 Complexity 螖
...urityscanner/v1alpha/WebSecurityScannerClient.java 63.59% <0%> (-2.92%) 55% <0%> (酶)
...curityscanner/v1beta/WebSecurityScannerClient.java 63.59% <0%> (-2.92%) 55% <0%> (酶)

Continue to review full report at Codecov.

Legend - Click here to learn more
螖 = absolute <relative> (impact), 酶 = not affected, ? = missing data
Powered by Codecov. Last update 33dabdc...b525bbe. Read the comment docs.

@kokoro-team kokoro-team removed the kokoro:run label Jan 3, 2020
@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Jan 8, 2020
@yoshi-kokoro yoshi-kokoro removed the kokoro:run label Jan 8, 2020
@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Jan 8, 2020
@yoshi-kokoro yoshi-kokoro removed the kokoro:run label Jan 8, 2020
@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Jan 10, 2020
@yoshi-kokoro yoshi-kokoro removed the kokoro:run label Jan 13, 2020
@trusted-contributions-gcf trusted-contributions-gcf bot added the kokoro:run label Jan 21, 2020
@chingor13
Copy link
Collaborator

@chingor13 chingor13 commented Jan 30, 2020

This combined with #48 passes the dependency check

@chingor13 chingor13 merged commit d2befdf into googleapis:master Jan 30, 2020
10 of 11 checks passed
@renovate-bot renovate-bot deleted the renovate/guava.version branch Jan 30, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
cla: yes kokoro:run
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

7 participants