Skip to content
Permalink
Browse files
fix(deps): require python 3.6 (#46)
`google-cloud-access-context-manager` is a proto only package that is only used by `google-cloud-asset`. The last version of `google-cloud-asset` that supports python 2.7 is `1.3.0`. See the [setup.py of version 1.3.0 here](https://github.com/googleapis/python-asset/blob/v1.3.0/setup.py#L34). In version `1.3.0` of `python-asset`, the version of `google-cloud-access-context-manager` that is required has an upper bound of `< 0.2.0dev`. Assuming that the SemVer minor version of `google-cloud-access-context-manager` increases after this PR, this change should not break users that are still on `python-asset` version `1.3.0`.
  • Loading branch information
parthea committed Jun 22, 2021
1 parent c340d13 commit 3a4c5def322acc5bd16bdbeafef6d3235b5eadab
Showing with 2 additions and 2 deletions.
  1. +2 −2 setup.py
@@ -62,18 +62,18 @@
"License :: OSI Approved :: Apache Software License",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Operating System :: OS Independent",
"Topic :: Internet",
],
platforms="Posix; MacOS X; Windows",
packages=packages,
namespace_packages=namespaces,
install_requires=dependencies,
python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*",
python_requires=">=3.6",
include_package_data=True,
zip_safe=False,
)

0 comments on commit 3a4c5de

Please sign in to comment.