Skip to content
Permalink
Browse files
fix(deps): pin 'google-{api,cloud}-core', 'google-auth' to allow 2.x …
…versions (#220)

Expand pins on library dependencies in preparation for these dependencies taking a new major version. See googleapis/google-cloud-python#10566.
  • Loading branch information
busunkim96 committed Jul 20, 2021
1 parent 836f37c commit bf1f47c794e747a2ea878347322c040636e8c2d4
Showing with 4 additions and 1 deletion.
  1. +4 −1 setup.py
@@ -66,7 +66,10 @@ def readme():
platforms="Posix; MacOS X; Windows",
install_requires=[
"google-api-core>=1.30.0", # Work-around bug in cloud core deps.
"google-auth>=1.25.0,<3.0dev", # Work around pip wack.
# NOTE: Maintainers, please do not require google-auth>=2.x.x
# Until this issue is closed
# https://github.com/googleapis/google-cloud-python/issues/10566
"google-auth>=1.25.0,<3.0.0dev", # Work around pip wack.
"google-cloud-bigquery>=2.19.0",
"sqlalchemy>=1.2.0,<1.5.0dev",
"future",

0 comments on commit bf1f47c

Please sign in to comment.