Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

deps: declare support for Python 3.9 #488

Merged
merged 6 commits into from Jan 27, 2021

Conversation

@plamut
Copy link
Contributor

@plamut plamut commented Jan 27, 2021

Towards #462.

With wheels for pyarrow==3.0.0 released we can now officially support Python 3.9 - well, at least after when we add Python 3.9 checks to Kokoro.

PR checklist:

  • Make sure to open an issue as a bug/issue before writing your code! That way we can discuss the change, evaluate designs, and agree on the general idea
  • Ensure the tests and linter pass
  • Code coverage does not decrease (if any source code was changed)
  • Appropriate docs were updated (if necessary)
@plamut plamut requested a review from as a code owner Jan 27, 2021
@plamut plamut requested review from shollyman and removed request for Jan 27, 2021
@google-cla google-cla bot added the cla: yes label Jan 27, 2021
@plamut plamut requested a review from tswast Jan 27, 2021
@plamut
Copy link
Contributor Author

@plamut plamut commented Jan 27, 2021

Oh, we need to bump the version in samples/, too.
Nah, only after we release BQ with Py3.9 support.

Loading

@plamut
Copy link
Contributor Author

@plamut plamut commented Jan 27, 2021

FWIW, I successfully ran unit and system test with Python 3.9 locally (Ubuntu).

Loading

setup.py Outdated
],
"pandas": [
"pandas>=0.23.0",
# pyarrow 1.0.0 is required for the use of timestamp_as_object keyword.
"pyarrow >= 1.0.0, < 3.0dev",
"pyarrow >= 3.0.0, < 4.0dev",
Copy link
Contributor

@tswast tswast Jan 27, 2021

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Ditto.

Loading

setup.py Outdated
@@ -45,12 +45,11 @@
# grpc.Channel.close() method isn't added until 1.32.0.
# https://github.com/grpc/grpc/pull/15254
"grpcio >= 1.32.0, < 2.0dev",
"pyarrow >= 1.0.0, < 3.0dev",
"pyarrow >= 3.0.0, < 4.0dev",
Copy link
Contributor

@tswast tswast Jan 27, 2021

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Can we keep this at 1.0 as a minimum? Or were there breaking changes we needed to account for?

Since pyarrow is a core library, the wider we can keep these dependencies, the fewer conflicts we'll get.

Loading

tswast
tswast approved these changes Jan 27, 2021
Copy link
Contributor

@tswast tswast left a comment

LGTM, assuming Python 3.6 tests pass with pyarrow==1.0.0

Loading

@tswast
Copy link
Contributor

@tswast tswast commented Jan 27, 2021

I pushed a commit that adds some variables for python versions to the noxfile. This is to align more closely with the central "synthtool" template.

Also, I remembered that we'll probably need pyarrow>=3.0 for #447, but I'd still like to avoid that requirement if at all possible, since BIGNUMERIC is less commonly used than is pyarrow 1&2 right now.

Loading

@tswast tswast changed the title process: declare support for Python 3.9 deps: declare support for Python 3.9 Jan 27, 2021
@gcf-merge-on-green gcf-merge-on-green bot merged commit 55daa7d into googleapis:master Jan 27, 2021
9 of 11 checks passed
Loading
@plamut plamut deleted the support-py-3.9 branch Jan 28, 2021
@tswast tswast mentioned this pull request Jan 28, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants