Skip to content
Permalink
Browse files
fix(deps): pin 'google-{api,cloud}-core', 'google-auth' to allow 2.x …
…versions (#71)

Expand pins on library dependencies in preparation for these dependencies taking a new major version. See googleapis/google-cloud-python#10566.
  • Loading branch information
busunkim96 committed Jul 20, 2021
1 parent ec33e60 commit 36ba3c36d9ffb37c1f156fd69f7216c331f55f87
Showing with 4 additions and 1 deletion.
  1. +4 −1 setup.py
@@ -45,7 +45,10 @@
platforms="Posix; MacOS X; Windows",
include_package_data=True,
install_requires=(
"google-api-core[grpc] >= 1.26.0, <2.0.0dev",
# NOTE: Maintainers, please do not require google-api-core>=2.x.x
# Until this issue is closed
# https://github.com/googleapis/google-cloud-python/issues/10566
"google-api-core[grpc] >= 1.26.0, <3.0.0dev",
"proto-plus >= 1.4.0",
"packaging >= 14.3",
),

0 comments on commit 36ba3c3

Please sign in to comment.