Skip to content
Permalink
Browse files
fix(deps): pin 'google-{api,cloud}-core', 'google-auth' to allow 2.x …
…versions (#9)

Expand pins on library dependencies in preparation for these dependencies taking a new major version. See googleapis/google-cloud-python#10566.
  • Loading branch information
busunkim96 committed Jul 21, 2021
1 parent cf3b882 commit e465487f8c682efdacaf977085d3143af2d146da
Showing 1 changed file with 4 additions and 1 deletion.
@@ -25,7 +25,10 @@
release_status = "Development Status :: 4 - Beta"
url = "https://github.com/googleapis/python-debugger-client"
dependencies = [
"google-api-core[grpc] >= 1.26.0, <2.0.0dev",
# NOTE: Maintainers, please do not require google-api-core>=2.x.x
# Until this issue is closed
# https://github.com/googleapis/google-cloud-python/issues/10566
"google-api-core[grpc] >= 1.26.0, <3.0.0dev",
"proto-plus >= 1.15.0",
"packaging >= 14.3",
"google-cloud-source-context >= 0.1.0, < 1.0.0dev",

0 comments on commit e465487

Please sign in to comment.