Skip to content
Permalink
Browse files
fix(deps): pin 'google-{api,cloud}-core', 'google-auth' to allow 2.x …
…versions (#43)

Expand pins on library dependencies in preparation for these dependencies taking a new major version. See googleapis/google-cloud-python#10566.
  • Loading branch information
busunkim96 committed Jul 21, 2021
1 parent cf622ac commit 27bf301320a1aad517fd2c9ea42c9b079e4a5cc4
Showing with 4 additions and 1 deletion.
  1. +4 −1 setup.py
@@ -25,7 +25,10 @@
release_status = "Development Status :: 5 - Production/Stable"
url = "https://github.com/googleapis/python-policy-troubleshooter"
dependencies = [
"google-api-core[grpc] >= 1.26.0, <2.0.0dev",
# NOTE: Maintainers, please do not require google-api-core>=2.x.x
# Until this issue is closed
# https://github.com/googleapis/google-cloud-python/issues/10566
"google-api-core[grpc] >= 1.26.0, <3.0.0dev",
"libcst >= 0.2.5",
"proto-plus >= 1.15.0",
"grpc-google-iam-v1",

0 comments on commit 27bf301

Please sign in to comment.