Skip to content
Permalink
Browse files
fix: restrict api-core dependency to < 1.17.0 (#76)
Version 1.17.0 causes problems on re-establishing streams on retryable
errors, thus restricting it.
  • Loading branch information
plamut committed Apr 16, 2020
1 parent 21e761e commit 191b0516335f5c60828a818ba79e99d6c68aa7bd
Showing with 4 additions and 1 deletion.
  1. +4 −1 setup.py
@@ -29,7 +29,10 @@
# 'Development Status :: 5 - Production/Stable'
release_status = "Development Status :: 5 - Production/Stable"
dependencies = [
"google-api-core[grpc] >= 1.14.0, < 2.0.0dev",
# google-api-core[grpc] 1.17.0 causes problems, thus restricting its
# version until the issue gets fixed.
# https://github.com/googleapis/python-pubsub/issues/74
"google-api-core[grpc] >= 1.14.0, < 1.17.0",
"grpc-google-iam-v1 >= 0.12.3, < 0.13dev",
'enum34; python_version < "3.4"',
]

0 comments on commit 191b051

Please sign in to comment.