Skip to content
Permalink
Browse files
fix(deps): add packaging requirement (#91)
Add packaging requirement. packaging.version
              is used for a version comparison in transports/base.py and is needed after the upgrade to gapic-generator-python 0.46.3
  • Loading branch information
busunkim96 committed May 15, 2021
1 parent 459b0f4 commit bf202ab5656cbd7dfdff6847310d4321c48735d4
Showing with 6 additions and 1 deletion.
  1. +5 −1 setup.py
  2. +1 −0 testing/constraints-3.6.txt
@@ -23,7 +23,11 @@
description = "Cloud Recommender API client library"
version = "2.1.0"
release_status = "Development Status :: 5 - Production/Stable"
dependencies = ["google-api-core[grpc] >= 1.22.2, < 2.0.0dev", "proto-plus >= 1.10.0"]
dependencies = [
"google-api-core[grpc] >= 1.22.2, < 2.0.0dev",
"proto-plus >= 1.10.0",
"packaging >= 14.3",
]
extras = {"libcst": "libcst >= 0.2.5"}
scripts = [
"scripts/fixup_recommender_v1_keywords.py",
@@ -7,3 +7,4 @@
# Then this file should have google-cloud-foo==1.14.0
google-api-core==1.22.2
proto-plus==1.15.0
packaging==14.3

0 comments on commit bf202ab

Please sign in to comment.