Skip to content
Permalink
Browse files
fix(deps): pin 'google-{api,cloud}-core', 'google-auth' to allow 2.x …
…versions (#96)

Expand pins on library dependencies in preparation for these dependencies taking a new major version. See googleapis/google-cloud-python#10566.
  • Loading branch information
busunkim96 committed Jul 20, 2021
1 parent 544742c commit ec30558ee8b89b951509e3f7b9cea6f548b69fe6
Showing with 4 additions and 1 deletion.
  1. +4 −1 setup.py
@@ -40,7 +40,10 @@
platforms="Posix; MacOS X; Windows",
include_package_data=True,
install_requires=(
"google-api-core >= 1.22.2, < 2.0.0dev",
# NOTE: Maintainers, please do not require google-api-core>=2.x.x
# Until this issue is closed
# https://github.com/googleapis/google-cloud-python/issues/10566
"google-api-core >= 1.22.2, <3.0.0dev",
"proto-plus >= 1.10.0",
"grpc-google-iam-v1",
"packaging >= 14.3",

0 comments on commit ec30558

Please sign in to comment.