Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

fix: pin six as a required dependency #589

Merged
merged 2 commits into from Sep 16, 2021
Merged

fix: pin six as a required dependency #589

merged 2 commits into from Sep 16, 2021

Conversation

@dandhlee
Copy link
Contributor

@dandhlee dandhlee commented Sep 16, 2021

six used to be a transitive dependency through protobuf, but now it is not specified in any of the other dependencies thus the tests are failing, and any other installations to the current latest version would fail.

protobuf also dropped support for Python 2.7 as of 3.18.0. Pinning it for 2.7.

Fixes #588 馃

@dandhlee dandhlee marked this pull request as ready for review Sep 16, 2021
@dandhlee dandhlee requested review from as code owners Sep 16, 2021
Copy link
Contributor

@cojenco cojenco left a comment

Thanks for pinning these!

@dandhlee dandhlee merged commit 9ca97bf into main Sep 16, 2021
12 checks passed
@dandhlee dandhlee deleted the dandhlee-patch-1 branch Sep 16, 2021
@@ -37,7 +37,9 @@
"google-resumable-media >= 1.3.0, < 2.0dev; python_version<'3.0'",
"google-resumable-media >= 1.3.0, < 3.0dev; python_version>='3.6'",
"requests >= 2.18.0, < 3.0.0dev",
"protobuf < 3.18.0; python_version<'3.0'",
Copy link
Contributor

@tseaver tseaver Sep 16, 2021

Should we be adding an un-pinned protobuf for Python 3.x (to avoid future transitive dep failures):

Suggested change
"protobuf < 3.18.0; python_version<'3.0'",
"protobuf < 3.18.0; python_version<'3.0'",
"protobuf; python_version>='3.6'",

cojenco added a commit to cojenco/python-storage that referenced this issue Oct 13, 2021
* fix: pin six as a required dependency

* chore: pin protobuf for older Python 2.7
cojenco added a commit to cojenco/python-storage that referenced this issue Oct 13, 2021
* fix: pin six as a required dependency

* chore: pin protobuf for older Python 2.7
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

4 participants