Skip to content
This repository has been archived by the owner. It is now read-only.

Testing GWT Gadget in hosted mode provokes error : Invalid version number "null" passed to external.gwtOnLoad(), expected "1.5" #199

Closed
GoogleCodeExporter opened this issue Sep 10, 2015 · 11 comments

Comments

@GoogleCodeExporter
Copy link

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

Found in Release: 1.5.2 + Gadget lib 1.0.0 RC1

Detailed description:

When launching a GWT gadget in hosted mode I get this error :

[ERROR] Invalid version number "null" passed to external.gwtOnLoad(),
expected "1.5"; your hosted mode bootstrap file may be out of date; if you
are using -noserver try recompiling and redeploying your app

You can clearly see that in the Gadget lib for GWT that in the file
com.google.gwt.gadgets.linker.GadgetTemplate.js
line 226 : external.gwtOnLoad($wnd, $wnd.$moduleName);

It's a piece of code that seems to be executed during the hosted mode
activation...

It also seems to me that there should be a 3rd parameter on the call of
this function (with the version number, here "1.5"). And it may be causing
the issue.

Workaround if you have one: Not found any. Maybe use an older version of
the GWT lib with the Gadget lib.


Links to the relevant GWT Developer Forum posts:

Original issue reported on code.google.com by Nivco.las@gmail.com on 22 Oct 2008 at 10:55

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

Original comment by galgwt.reviews@gmail.com on 22 Oct 2008 at 2:28

  • Changed state: Accepted
  • Added labels: API-Gadgets, Milestone-1_0_RC
@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

Committed as r925.

Original comment by galgwt.reviews@gmail.com on 22 Oct 2008 at 2:53

  • Changed state: FixedNotReleased
@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

Original comment by galgwt.reviews@gmail.com on 6 Nov 2008 at 6:42

  • Changed state: Fixed
@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

I am still getting the same issue with GWT1.6 in jetty hosted mode and a gadget
developed with gwt-gadgets-1.0.3, GWT1.5.3.

The error is as follows

[ERROR] Invalid version number "1.5" passed to external.gwtOnLoad(), expected 
"1.6";
your hosted mode bootstrap file may be out of date; if you are using -noserver 
try
recompiling and redeploying your app


[ERROR] Failure to load module 'com.test.gadget.TestGadget'
com.google.gwt.dev.shell.ie.IDispatchImpl$HResultException: -2147024809
    at
com.google.gwt.dev.shell.ie.BrowserWidgetIE6$External.gwtOnLoad(BrowserWidgetIE6
.java:63)
    at
com.google.gwt.dev.shell.ie.BrowserWidgetIE6$External.invoke(BrowserWidgetIE6.ja
va:161)
    at com.google.gwt.dev.shell.ie.IDispatchImpl.Invoke(IDispatchImpl.java:294)
    at com.google.gwt.dev.shell.ie.IDispatchImpl.method6(IDispatchImpl.java:194)
    at org.eclipse.swt.internal.ole.win32.COMObject.callback6(COMObject.java:117)
    at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
    at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:1925)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2966)
    at com.google.gwt.dev.SwtHostedModeBase.processEvents(SwtHostedModeBase.java:235)
    at com.google.gwt.dev.HostedModeBase.pumpEventLoop(HostedModeBase.java:558)
    at com.google.gwt.dev.HostedModeBase.run(HostedModeBase.java:405)
    at com.google.gwt.dev.HostedMode.main(HostedMode.java:232)


Original comment by hafiza...@gmail.com on 20 May 2009 at 6:19

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

You must recompile your gadget with 1.6 to debug with 1.6 hosted mode.

Original comment by galgwt.reviews@gmail.com on 20 May 2009 at 1:11

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

Thanks for the response.

I tried compiling the application with the same dependencies as i am running my 
gwt
application, but I am still getting the error

Basically i am developing an opensocial container with gwt and i am trying to 
add a
gadget that i developed into the gwt based shindig container.

Any help is greatly appreciated.

Best Regards,
Hafiz

Original comment by hafiza...@gmail.com on 21 May 2009 at 12:31

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

Even after re-compiling and deploying your gadgets.  Your gadget spec will be 
cached
for about an hour.  On iGoogle, there is a developer.xml gadget that can turn 
off
caching on the gadget spec.

Original comment by galgwt.reviews@gmail.com on 21 May 2009 at 12:37

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

Still struggling to debug my gwt gadget in my gwt based open social container. 
I need
to build and deploy the container application to jboss and check for every 
small change. 

Btw i have nocache=1 for my iframe url.

Pulling my hairs on all those wasted hours.

Best Regards,
Hafiz

Original comment by hafiza...@gmail.com on 2 Jun 2009 at 9:11

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

Hafiz, please join the gwt-google-apis discussion list and get this 
straightened out.  
The problem you reported has long since been fixed and I don't think it is 
relevant to 
the issue you are having.

Original comment by ericzun...@gmail.com on 2 Jun 2009 at 11:29

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

Thank you Eric for the responses, I am trying my luck at the groups
-.http://groups.google.com/group/gwt-google-apis/browse_thread/thread/80eef7e633
92d3aa#

Best Regards,
Hafiz

Original comment by hafiza...@gmail.com on 2 Jun 2009 at 1:05

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Sep 10, 2015

This is a new problem when using GWT 1.6 with the distributed gwt-gadgets.jar 
file. 
See issue 275.

Original comment by galgwt.reviews@gmail.com on 3 Jun 2009 at 2:41

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant