Skip to content
Permalink
Browse files

doc: Document Node.js version 10.0.0 requirement.

Updates #809.
  • Loading branch information...
dmitshur committed Jun 28, 2018
1 parent 5232e51 commit 0892b62f0d9fb5857760c3cfca837207185117ee
Showing with 2 additions and 2 deletions.
  1. +1 −1 README.md
  2. +1 −1 doc/syscalls.md
@@ -27,7 +27,7 @@ Now you can use `gopherjs build [package]`, `gopherjs build [files]` or `gopherj

#### gopherjs run, gopherjs test

If you want to use `gopherjs run` or `gopherjs test` to run the generated code locally, install Node.js 4.x (or newer), and the `source-map-support` module:
If you want to use `gopherjs run` or `gopherjs test` to run the generated code locally, install Node.js 10.0.0 (or newer), and the `source-map-support` module:

```
npm install --global source-map-support
@@ -13,7 +13,7 @@ The JavaScript environment of a web browser is completely isolated from your ope

### Node.js on Linux and macOS

GopherJS has support for system calls on Linux and macOS. Before running your code with Node.js, you need to install the system calls module. The module is compatible with Node.js version 0.12 and above. If you want to use an older version you can opt to not install the module, but then system calls are not available.
GopherJS has support for system calls on Linux and macOS. Before running your code with Node.js, you need to install the system calls module. The module is compatible with Node.js version 10.0.0 (or newer). If you want to use an older version you can opt to not install the module, but then system calls are not available.

Compile and install the module with:

0 comments on commit 0892b62

Please sign in to comment.
You can’t perform that action at this time.