Skip to content
Permalink
Browse files

target Go 1.13 Beta 1, update version to GopherJS 1.13-wip

  • Loading branch information...
dmitshur committed Jul 25, 2019
1 parent 5d27143 commit cf2e4059f76a442caeed3f661953e9cf3633a9da
Showing with 6 additions and 6 deletions.
  1. +1 −1 circle.yml
  2. +1 −1 compiler/compiler.go
  3. +4 −4 compiler/version_check.go
@@ -11,7 +11,7 @@ jobs:
- checkout
- run: git clone https://github.com/creationix/nvm $HOME/.nvm && cd $HOME/.nvm && git checkout v0.33.9 && echo 'export NVM_DIR="$HOME/.nvm"' >> $BASH_ENV && echo '[ -s "$NVM_DIR/nvm.sh" ] && \. "$NVM_DIR/nvm.sh"' >> $BASH_ENV
- run: nvm install 10.0.0 && nvm alias default 10.0.0
- run: cd /usr/local && sudo rm -rf go && curl https://storage.googleapis.com/golang/go1.12.linux-amd64.tar.gz | sudo tar -xz
- run: cd /usr/local && sudo rm -rf go && curl https://storage.googleapis.com/golang/go1.13beta1.linux-amd64.tar.gz | sudo tar -xz
- run: echo 'export PATH="$PATH:/usr/local/go/bin:$HOME/go/bin"' >> $BASH_ENV
- run: go get -t -d -v ./...
- run: go install -v
@@ -17,7 +17,7 @@ import (

var sizes32 = &types.StdSizes{WordSize: 4, MaxAlign: 8}
var reservedKeywords = make(map[string]bool)
var _ = ___GOPHERJS_REQUIRES_GO_VERSION_1_12___ // Compile error on other Go versions, because they're not supported.
var _ = ___GOPHERJS_REQUIRES_GO_VERSION_1_13___ // Compile error on other Go versions, because they're not supported.

func init() {
for _, keyword := range []string{"abstract", "arguments", "boolean", "break", "byte", "case", "catch", "char", "class", "const", "continue", "debugger", "default", "delete", "do", "double", "else", "enum", "eval", "export", "extends", "false", "final", "finally", "float", "for", "function", "goto", "if", "implements", "import", "in", "instanceof", "int", "interface", "let", "long", "native", "new", "null", "package", "private", "protected", "public", "return", "short", "static", "super", "switch", "synchronized", "this", "throw", "throws", "transient", "true", "try", "typeof", "undefined", "var", "void", "volatile", "while", "with", "yield"} {
@@ -1,9 +1,9 @@
// +build go1.12
// +build !go1.13
// +build go1.13
// +build !go1.14

package compiler

const ___GOPHERJS_REQUIRES_GO_VERSION_1_12___ = true
const ___GOPHERJS_REQUIRES_GO_VERSION_1_13___ = true

// Version is the GopherJS compiler version string.
const Version = "1.12-2"
const Version = "1.13-wip"

0 comments on commit cf2e405

Please sign in to comment.
You can’t perform that action at this time.