Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Trouble installing gopherjs #931

Closed
limitlessloop opened this issue Jul 20, 2019 · 4 comments

Comments

@limitlessloop
Copy link

commented Jul 20, 2019

Hi,

I'm having trouble installing gopherjs.

I ran

go get -u github.com/gopherjs/gopherjs

And nothing is returned in the command line.

I followed these instructions to make sure my PATH was correct

https://github.com/golang/go/wiki/SettingGOPATH

But still can't get it to work.

Any suggestions?

@dmitshur dmitshur added the question label Jul 20, 2019

@dmitshur

This comment has been minimized.

Copy link
Member

commented Jul 20, 2019

nothing is returned in the command line

Nothing being printed is often the expected outcome when when a command succeeds. Can you check the exit code that go get -u github.com/gopherjs/gopherjs returns? Did you check your $GOPATH/bin directory to see if a gopherjs binary was installed there?

Also, what OS are you on, and what does go version print?

@limitlessloop

This comment has been minimized.

Copy link
Author

commented Jul 20, 2019

Nothing being printed is often the expected outcome when a command succeeds.

Thanks. Most installations I've used show some sort of progress so I wasn't sure if this was the case or not.

I can confirm the binary is there and my $GOPATH/bin links to it. When I type gopherjs` in the terminal it says unkown command.

I'm on macOS and the version is

go version go1.12.7 darwin/amd64

I'm unfamiliar with go so I'm not sure if there's anything else I'm supposed to do. I created a hello world app and was able to run that using go.

Appologies for not being very useful, I'm completely new to go and gopherjs, trying to get a version of jsonnet working for a js project.

@limitlessloop

This comment has been minimized.

Copy link
Author

commented Jul 20, 2019

Ok I managed to fix it. My PATH was not correctly loading $GOPATH/bin. I'm not sure why because /usr/local/go/bin is in my PATH. I've manually added :$GOPATH/bin to the end of my PATH and it seems to be working. Thanks again for your help.

@dmitshur

This comment has been minimized.

Copy link
Member

commented Jul 20, 2019

I've manually added :$GOPATH/bin to the end of my PATH and it seems to be working.

Yep, this needs to be done manually. In contrast, /usr/local/go/bin gets added to PATH by the macOS installer which you probably used.

Thanks again for your help.

No problem! 👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.