The do-not-repeat-yourself-library. All your utils.py and compat.py are belong to us. Python 2.5+, PyPy, and Python 3.x
Python Shell
Latest commit 6a54279 Jan 6, 2013 @gorakhargosh Bug fix version.

README

Extra batteries for Python.

Every time you copy-and-paste code into a utils.py God kills a Unicorn.
Please do not repeat yourself. Evolve this library instead.

The library works with Python 2.5+, PyPy, and Python 3.x.
The RSA cryptography modules depend on pyasn1, which has not
been ported to Python 3.x, so this is pending.

Please visit: http://gorakhargosh.github.com/mom/ for more information.