Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cosmetic filters not always reported by logger on Firefox 42 if you refresh the page #876

Closed
anewuser opened this issue Oct 28, 2015 · 1 comment
Labels

Comments

@anewuser
Copy link
Contributor

@anewuser anewuser commented Oct 28, 2015

Please try to reproduce this:

  1. Enable the RUS: BitBlock and Fanboy’s Annoyance lists
  2. Open https://www.kifi.com/signup or http://anonymouse.org/cgi-bin/anon-www.cgi/http://handycache.ru/
  3. Watch the logger and refresh the page a couple of times

On Chrome, uBlock Origin 1.2.0 reports the cosmetic filters every time I refresh the page:
untitled-1

On Firefox 42 Beta though, uBlock Origin 1.3.1 most often doesn't show me the cosmetic filters :
untitled-1

Despite this problem with the logger, the filters are still correctly applied and all elements are hidden accordingly to the filter lists.

I wonder if this has something to do with my Firefox cache settings or other extensions. Anyway, since those are cosmetic filters, I assume that they should always be listed.

My current settings:

untitled-2

@gorhill gorhill added the accepted label Oct 28, 2015
@gorhill

This comment has been minimized.

Copy link
Owner

@gorhill gorhill commented Oct 28, 2015

I can reproduce.

I am guessing the script to survey filtered DOM elements is being executed before DOMContentLoaded.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.