Skip to content
FPTU Javascript SDK for implementing the web client API
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
dist
src
.dockerignore
.editorconfig
.gitignore
.npmignore
Dockerfile
README.md
jest.config.js
package.json
tsconfig.json
webpack.config.js
yarn.lock

README.md

FPTU Javascript SDK

A simple SDK for scaffolding FPTU.tech projects.

Installation

Prerequisites: Node.js (>=6.x, 8.x preferred), npm version 3+ and Git.

Install as a library

$ npm install fptu-sdk

Build universal javascript

  • Install yarn npm install yarn -g.
  • Clone project, run yarn and yarn build, get file fptu-sdk.js from /dist/ folder.
  • You may upload that javascript file to a CDN for later use.
  • If you don't want to build you can use that file here: https://cdn.jsdelivr.net/npm/fptu-sdk@[version,eg:1.0.2]/dist/fptu-sdk.js

How to use SDK universal javascript

  • Add <script src="fptu-sdk.js"></script> to your index.html.
  • Deal with the window.FPTUSDK global, and you got the world!

Usage

Example:

const sdk = require("fptu-sdk");

// Get overview
sdk.overview.getOverview().then(data => console.log(data));
You can’t perform that action at this time.